Bug 4806 - The right "allowedChildClassesEffective"s for schema
The right "allowedChildClassesEffective"s for schema
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
All All
: P3 normal
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 09:59 UTC by Matthias Dieter Wallnöfer
Modified: 2007-07-26 22:09 UTC (History)
0 users

See Also:


Attachments
Attempt to prive allowedChildClasses (6.46 KB, patch)
2007-07-24 08:05 UTC, Andrew Bartlett
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Dieter Wallnöfer 2007-07-20 09:59:41 UTC
Is there also a plan to introduce the right allowChildClassesEffective attributes in the schema entries? So for example it could be possible to create OUs.
Comment 1 Andrew Bartlett 2007-07-22 22:02:56 UTC
I need to look into the details of the implementation, but yes, that's the aim. 
Comment 2 Andrew Bartlett 2007-07-24 08:05:39 UTC
Created attachment 2840 [details]
Attempt to prive allowedChildClasses

This is my first cut at making this work, but I return drasticly different results to what my win2k3 network returns, so I need to look into things a bit more.
Comment 3 Matthias Dieter Wallnöfer 2007-07-24 18:56:59 UTC
I tried to apply the patch with "patch < allowedChildClasses.patch" in my SAMBA source directory, but I then the software didn't work anymore and I got a stacktrace after recompile and restart. Maybe I have to notice something, for example a special SVN version?
Comment 4 Andrew Bartlett 2007-07-24 19:01:56 UTC
with the patch applied try:

svn update
make clean all

I think the issue is the changed header file, and you need to recomple from scratch.  For speed when doing this in future, install 'ccache'. 
Comment 5 Matthias Dieter Wallnöfer 2007-07-25 09:25:52 UTC
Thanks, now the patch and SAMBA worked. Now I have noticed another thing: I cannot move an object in ADUC to a newly created OU, because it isn't listed in the dialogbox.
Comment 6 Matthias Dieter Wallnöfer 2007-07-25 09:55:51 UTC
Also surprisingly, now I am unable to add users and groups under the CN=Users container in ADUC.
Comment 7 Matthias Dieter Wallnöfer 2007-07-25 10:03:26 UTC
(In reply to comment #6)
> Also surprisingly, now I am unable to add users and groups under the CN=Users
> container in ADUC.
> 

I've solved that problem. I had an "allowedChildClassesEffective" entry in the LDB database under the "CN=Users" object.
Comment 8 Andrew Bartlett 2007-07-26 22:09:13 UTC
This might need more work, but an initial fix is in -r 24060.

Thanks!