Bug 4789 - net ads join fails with 3.0.25b - works with 3.0.20b
net ads join fails with 3.0.25b - works with 3.0.20b
Status: RESOLVED DUPLICATE of bug 4866
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.25b
Sparc Solaris
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-16 06:08 UTC by Svein Olav Bjerkeset
Modified: 2013-02-18 13:30 UTC (History)
1 user (show)

See Also:


Attachments
Debug output / config files / snoop output (7.13 KB, application/x-zip-compressed)
2007-07-16 06:11 UTC, Svein Olav Bjerkeset
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Svein Olav Bjerkeset 2007-07-16 06:08:13 UTC
Joining a client to an AD domain fails with Samba 3.0.25b on Solaris 10 (Sparc). The command I have used is:

# net ads join -S svvdc2.vegvesen.no -U adminvdt@VEGVESEN.NO

The output from 'net ads join' is (I have replaced the actual account name I used with <admin account>):

[2007/07/16 12:22:44, 0] libads/kerberos.c:ads_kinit_password(228)
  kerberos_kinit_password <admin account>@VEGVESEN.NO failed: Preauthentication failed
Failed to join domain: Logon failure

I am sure the password is correct, and I have no problem geting a ticket with kinit, using the same account and password.

I can use the exact same config on samba 3.0.20b (compiled with the same configure options) on the same box and successfully join the domain. After the client has been joined to the domain, I can copy the file secrets.tdb to the 3.0.25b installation, and it works.
Comment 1 Svein Olav Bjerkeset 2007-07-16 06:11:30 UTC
Created attachment 2821 [details]
Debug output / config files / snoop output
Comment 2 Eric Diven 2007-10-04 15:23:15 UTC
If your password is longer than 8 characters, you're going to run into this issue:
https://bugzilla.samba.org/show_bug.cgi?id=4863

That's a duplicate of another bug:
https://bugzilla.samba.org/show_bug.cgi?id=4866

It took the better part of a day to find the cause.  This bug is not present in 3.0.24, which is what I've been using on Solaris 10 for exactly this reason.
Comment 3 Svein Olav Bjerkeset 2007-11-27 06:23:25 UTC

*** This bug has been marked as a duplicate of 4866 ***