Bug 4754 - smbd/nmdb not installing using binary dist on AIX 5L V5.3
smbd/nmdb not installing using binary dist on AIX 5L V5.3
Product: Samba 3.0
Classification: Unclassified
Component: Packaging
: P3 regression
: none
Assigned To: William Jojo
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2007-06-29 10:55 UTC by Bob Zwolinski
Modified: 2007-06-29 16:33 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Bob Zwolinski 2007-06-29 10:55:14 UTC
The 3.0.24 binary distribution from samba.org for AIX installed only base support files and not samba (e.g. smbd/nmbd). A build/packaging issue?
Comment 1 Gerald (Jerry) Carter 2007-06-29 11:01:14 UTC
Reassigning to Bill as the AIX package dude.
Comment 2 William Jojo 2007-06-29 12:06:15 UTC

Can you tell me more about the install? did you extract both the base and samba to the same dir and then follow the install instructions in the README and:

lslpp -l pware.samba*

doesn't show the samba package as installed?


Comment 3 Bob Zwolinski 2007-06-29 15:23:00 UTC

When I placed the untar'd contents from both archives in the same directory, it installed correctly (below - thanks for the hint), but now neither daemon starts. I created an smb.conf file but it's not clear in which directory it should lie. I've tried a couple of different directories but no luck yet.

BTW, the readme in the binary dist does not explicitly state that both archives need to be untar'd in the same place.

root@bos-devaix1:lslpp -l pware.samba*
  Fileset                      Level  State      Description
Path: /usr/lib/objrepos
  pware.samba-3.0.24.rte  COMMITTED  Samba 3.0.24
Comment 4 Bob Zwolinski 2007-06-29 16:33:19 UTC

Everything is up and running. Thanks for your help!

Best Regards,
Bob Zwolinski