Bug 4740 - INVALID_HANDLE with NETLOGON pipe on local machine
INVALID_HANDLE with NETLOGON pipe on local machine
Status: RESOLVED DUPLICATE of bug 4579
Product: Samba 3.0
Classification: Unclassified
Component: winbind
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2007-06-25 09:30 UTC by Andreas Pflug
Modified: 2007-06-25 09:43 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Pflug 2007-06-25 09:30:00 UTC
I've got a running 3.0.25a PDC over OpenLDAP, but winbindd -d4 will claim "could not open handle to NETLOGON PIPE" when queried with wbinfo -t. I examined the problem and found:
cli_rpc_pipe_open is called with cli=0, because init_dc_connection doesn't initialize it on the local machine.

My hack is patching winbindd_cm.c:cm_connect_netlogon() to temporarily force domain->internal to zero before calling init_dc_connection(), but I guess it really should call init_dc_connection_network(), with the check for internal domains moved from init_dc_connection_network() to init_dc_connection().
Comment 1 Gerald (Jerry) Carter 2007-06-25 09:43:29 UTC

*** This bug has been marked as a duplicate of 4579 ***