Bug 4736 - umount.cifs error: This utility only unmounts cifs filesystems.
umount.cifs error: This utility only unmounts cifs filesystems.
Status: RESOLVED FIXED
Product: CifsVFS
Classification: Unclassified
Component: user space tools
2.6
Other Linux
: P3 normal
: ---
Assigned To: Steve French
http://bugs.debian.org/383375
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-23 09:39 UTC by Debian samba package maintainers (PUBLIC MAILING LIST)
Modified: 2008-12-06 02:12 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Debian samba package maintainers (PUBLIC MAILING LIST) 2007-06-23 09:39:30 UTC
Hello,

Using kernel 2.6.18 with samba 3.0.25a.

I'm mounting a cifs:

ibook:~# mount -t cifs -o username=noel //localhost/test /mnt/samba/
Password:
ibook:~# df
...
//localhost/test       5382836   5241872    140964  98% /mnt/samba

everthing fine. Then I want to unmount it again:

ibook:~# umount.cifs /mnt/samba/
ibook:~# df

//localhost/test       5382836   5132516    140948  98% /mnt/samba

Hmm, its still there.

ibook:~# umount /mnt/samba/
This utility only unmounts cifs filesystems.
This utility only unmounts cifs filesystems.

ibook:~# umount.cifs /mnt/samba
This utility only unmounts cifs filesystems.

$ cat /etc/mtab
...
//localhost/test /mnt/samba cifs rw,mand 0 0

But the directoy is empty and the samba server doesn't have a smb connection anymore.

thx.

noel@d.o
Comment 1 Steve Langasek 2007-11-25 03:47:00 UTC
this is a duplicate of bug #4784, which has been fixed in 3.0.27a.
Comment 2 Steve French 2008-12-05 14:15:33 UTC
Can you check whether the unmount actually worked but did not properly update mtab (the real list of what is mounted can be seen by "cat /proc/mounts")?

We made a fix to mtab handling in mount.cifs recently which would probably resolve this in any case.
Comment 3 Debian samba package maintainers (PUBLIC MAILING LIST) 2008-12-06 02:12:06 UTC
The Debian bug, which this bug is linked to was marked a fixed, so we can just close that one as well