Bug 4723 - remove "Using samba" html documentation/book from 3.0 releases
remove "Using samba" html documentation/book from 3.0 releases
Product: Samba 3.5
Classification: Unclassified
Component: Docs
Other Linux
: P3 enhancement
: ---
Assigned To: Samba Bugzilla Account
Samba Documentation QA Contact~
: 7002 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2007-06-22 09:59 UTC by Debian samba package maintainers (PUBLIC MAILING LIST)
Modified: 2010-01-20 06:21 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Debian samba package maintainers (PUBLIC MAILING LIST) 2007-06-22 09:59:12 UTC

a user read the "Using samba" html documentation/book and now reported a bug that capter 6 the logging options are not correct.

Only in samba-3.0.25a/docs/htmldocs/index.html there is the info:

"Using Samba, Second Edition is a comprehensive guide to Samba administration. It covers all versions of Samba from 2.0 to 2.2, including selected features from an alpha version of 3.0, as well as the SWAT graphical configuration tool. Updated for Windows 2000, ME, and XP, the book also explores Samba's new role as a primary domain controller and domain member server, its support for the use of Windows NT/2000/XP authentication and filesystem security on the host Unix system, and accessing shared files and printers from Unix clients."

If you go directly into using_samba/ or use the online version on samba.org there is not this information.

I would suggest to remove this documentation from the 3.0.x releases or at least to add an information about the version like its done in the manpage
"This man page is correct for version 3.0 of the Samba suite."

I'm not happy to ask for this removal of this good book but if its outdated and confuses the user it makes sense IMHO.

Whats your opinion about this?


Comment 1 Gerald (Jerry) Carter 2007-06-27 14:14:09 UTC
I'll remove the 2ed once I have the HTML files from the 3rd 
ed. to replace them.  I'll ping Andy @ O'Reilly again about this.
Comment 2 Debian samba package maintainers (PUBLIC MAILING LIST) 2009-01-25 11:50:23 UTC
I'm afraid that "Using Samba" is still the 2nd edition, even in 3.3.0

Isn't there any possibility to provide the 3rd edition, as Jerry mentioned back in 2007?
Comment 3 Karolin Seeger 2009-10-30 10:44:29 UTC
As the 3rd edition is not available yet, we shouldn't ship 3.5 with the old version. Are there any objections? 
Comment 4 Karolin Seeger 2010-01-20 06:18:42 UTC
*** Bug 7002 has been marked as a duplicate of this bug. ***
Comment 5 Karolin Seeger 2010-01-20 06:21:07 UTC
Using Samba 2nd edition will not be included in the 3.5 tarballs.
Closing out bug report.