Bug 4679 - winbindd does not start
winbindd does not start
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.25a
Other Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 02:12 UTC by DanB
Modified: 2007-06-09 13:05 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DanB 2007-06-04 02:12:37 UTC
winbindd silently fails to start because it tries to unlink /var/run/samba/winbindd_cache.tdb which does not exist

Creating the file by hand solves the problem until the next restart

strace:

...
stat64("/var/run/samba", {st_mode=S_IFDIR|0755, st_size=576, ...}) = 0
unlink("/var/run/samba/winbindd_cache.tdb") = -1 ENOENT (No such file or directory)
stat64("/var/run/samba", {st_mode=S_IFDIR|0755, st_size=576, ...}) = 0
exit_group(1)                           = ?
Comment 1 Simo Sorce 2007-06-09 13:05:28 UTC
This is a packaging problem, it was present both in the Ubuntu packages and my debian packages on samba.org, and was caused by a bug in the fhs.patch made originally by debian developers.

I fixed my packages and from my analysis this shouldn't happen in vanilla samba.
Closing the bug, reopen if there are still problems.