Bug 4662 - winbind nsswitch glue fails for users; winbind segfaults
winbind nsswitch glue fails for users; winbind segfaults
Status: RESOLVED DUPLICATE of bug 4624
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.25a
x86 Linux
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 20:53 UTC by James Ralston
Modified: 2007-06-09 15:42 UTC (History)
0 users

See Also:


Attachments
samba "log level = 10" log files (78.28 KB, application/x-gzip)
2007-05-25 20:59 UTC, James Ralston
no flags Details
idmap_rid patch (2.10 KB, patch)
2007-06-09 15:02 UTC, Simo Sorce
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Ralston 2007-05-25 20:53:46 UTC
Alas, after spending the better part of a week banging on it, I've concluded that winbind in 3.0.25 and onwards is broken to the point of being unusable.

The first problem is that perturbing the BUILTIN domain in any way causes winbind to segfault.  When I built against revision 23088 of SAMBA_3_0_25, winbind would at least run without crashing as long as I didn't refer to the BUILTIN domain in any way in smb.conf.  But when I rebuilt against revision 23147 of SAMBA_3_0_25, now winbind crashes a few seconds after startup, every time.

The second problem is that looking up users via the nsswitch.conf glue fails, even though looking up groups succeeds, and "wbinfo -u" and "wbinfo -g" return expected results.

Samba 3.0.24 works perfectly with the exact same smb.conf file.
Comment 1 James Ralston 2007-05-25 20:59:15 UTC
Created attachment 2729 [details]
samba "log level = 10" log files

Here's a tarball of assorted logs.

The top-level directory contains the smb.conf I'm using, for both 3.0.24 and 3.0.25+.

The 3.0.24 subdirectory contains "log level = 10" logs from Samba 3.0.24.  I cleared the logs, started samba, ran the command "getent passwd ada", then shut down Samba.

The 3.0.25 subdirectory contains the same, but winbind had already crashed before I ran the getent command.  Rather than including the core files (which probably wouldn't be useful to you), I've included the output of gdb's "thread apply all bt" and "info registers" commands.
Comment 2 James Ralston 2007-05-25 21:02:34 UTC
Finally, I'm well-versed in Subversion, patching, and rolling packages, so I'm happy to test patches, or to keep repulling against SAMBA_3_0_25.
Comment 3 Gerald (Jerry) Carter 2007-05-25 22:20:42 UTC
Thanks.  I'll deal with this but it will be mid next week before I can get to it,
Comment 4 Simo Sorce 2007-06-09 15:02:11 UTC
Created attachment 2745 [details]
idmap_rid patch

The patch should make idmap_rid a bit more robust and support for older configurations.
IT will sitll NOT support the, always defined as experimental, multiple domain config switch. That is replaced by the new configuration options.

Alsop the BUILTIN domain is now handled internally. If you rely on BUILTIN groups (aliases) just make sure they are correctly mapped using net groupmap.
Comment 5 Simo Sorce 2007-06-09 15:26:26 UTC

*** This bug has been marked as a duplicate of 4624 ***
Comment 6 Simo Sorce 2007-06-09 15:42:06 UTC
Comment on attachment 2745 [details]
idmap_rid patch

See the corrected patch attached to #4624