Bug 4626 - Microsoft programs overwrite default mask
Microsoft programs overwrite default mask
Status: RESOLVED DUPLICATE of bug 4625
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.24
Sparc Solaris
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-16 14:43 UTC by mags
Modified: 2007-05-16 14:51 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mags 2007-05-16 14:43:21 UTC
I have a Unix directory on a Solaris 10 machine with permission set using ACL as follows:

# file: testdir
# owner: sftp
# group: student
user::rwx
user:user1:rwx         #effective:rwx
user:user2:rwx          #effective:rwx
group::---              #effective:---
mask:rwx
other:---
default:user::rw-
default:user:user1:rwx
default:user:user2:rwx
default:user:sftp:rwx
default:group::---
default:mask:rwx
default:other:---

When user1 drops a file - copies it from a directory on the windows machine - into this share (testdir), it gets the following permissions:

# file: testfile
# owner: user1
# group: student
user::rwx
user:user1:rwx         #effective:rw-
user:user2:rwx          #effective:rw-
user:sftp:rwx                #effective:rw-
group::---              #effective:---
mask:rw-
other:---

Which is correct.  However, if he uses MS word or Excel and "Save As" directly to the testdir share, it gets the following permissions:

# file: testfile
# owner: user1
# group: student
user::rwx
user:user1:rwx         #effective:-w-
user:user2:rwx          #effective:-w-
user:sftp:rwx                #effective:-w-
group::---              #effective:---
mask:-w-
other:---

Which is wrong?

I have tried to change samba options, but no luck. The current options are as follows:

[testdata]
   comment = Transfer area
   browseable = no
   read only = no
   path = /home/sftp/Data
   public = no
   writeable = yes
   inherit permissions = yes
   create mask = 0700

   #force create mode = 0660
   #force directory mode = 0770
   #create mask = 0000
   #directory mask = 0000
   #force create mode = 0660
   #nt acl support = no
   #security mask = 0000
   #inherit acls = yes


PS. the commented options are some of my tries.

Thanks,
Comment 1 Volker Lendecke 2007-05-16 14:51:02 UTC

*** This bug has been marked as a duplicate of 4625 ***