Bug 462 - Listing of files with forbidden characters not complete via Windows Explorer.
Listing of files with forbidden characters not complete via Windows Explorer.
Status: RESOLVED WONTFIX
Product: Samba 2.2
Classification: Unclassified
Component: File Services
2.2.8a
Other AIX
: P3 major
: ---
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-17 00:30 UTC by Ronny Wouters
Modified: 2004-02-17 08:45 UTC (History)
1 user (show)

See Also:


Attachments
The directory listing from AIX (18.52 KB, text/plain)
2003-09-17 01:20 UTC, Ronny Wouters
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ronny Wouters 2003-09-17 00:30:40 UTC
I have an exported directory on Unix where the filenames have all kinds of 
forbidden characters (*:>'& amongst others).
The directory has 386 files.
When I look at the directory from windows explorer, there are only 382 files. 
When I start searching, there are indeed some files he does not list, but 
those files have plain names (without any forbidden characters). (Also the 
file before the files he does not show have plain names)

When I create a new file (Directly on AIX or via the Windows Explorer) he 
suddenly shows all files, including the files I could not see before. When I 
delete that file he goes back to the previous state (not showing all files).

Also when I do a dir from a cmd-box, the listing is complete.
When I try to create the file I cannot see, he gives the error "file already 
exists".

When I set the option "Mangled Names" to "No", I see all the files. But I then 
cannot directly open the files from Windows because of the forbidden 
characters.
Choosing another "Mangle Character" does not help.

AIX level: 4.3.3 ML 10
Windows: Windows XP (with all updates from the update website)
Comment 1 Ronny Wouters 2003-09-17 01:20:15 UTC
Created attachment 145 [details]
The directory listing from AIX

This is the directory listing from AIX (With all files).
If you share a directory with these files in, you should be able to reproduce
the problem.
(On Windows look at the file : EMILE_LINK_170-36203-001_NC_H700.model)
Comment 2 Gerald (Jerry) Carter 2004-02-17 08:45:38 UTC
Sorry, but the 2.2 is not under development any longer.
If you can reproduce this bug against the latest 3.0 release, 
please reopen this bug and change the version in the report.
Thanks.