Bug 4617 - netlogon is broken in 3.0.25
netlogon is broken in 3.0.25
Status: RESOLVED DUPLICATE of bug 4619
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.25
x86 Linux
: P3 normal
: 3.0.25
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-15 04:20 UTC by Patrick Rynhart
Modified: 2007-05-22 07:16 UTC (History)
0 users

See Also:


Attachments
smb.conf.txt (2.19 KB, text/text)
2007-05-15 04:40 UTC, Patrick Rynhart
no flags Details
updated smb.conf file (2.13 KB, text/plain)
2007-05-16 00:17 UTC, Patrick Rynhart
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Rynhart 2007-05-15 04:20:07 UTC
When acting as a PDC, the netlogon share is no longer accessible from Windows clients when upgrading from 3.0.23d to 3.0.25

Start -> Run and entering \\SERVER\netlogon results in

\\SERVER\netlogon refers to a location that is unavailable. It could be on a hard drive on this computer, or on a network etc...

If I rename my netlogon share to "netlogon2" in smb.conf and restart Samba then I can access the directory from Windows clients (but netlogon.bat isn't executed of course so this doesn't help).

If I downgrade to 3.0.23d then the netlogon share is accessible. In both cases I am using the same smb.conf file.
Comment 1 Patrick Rynhart 2007-05-15 04:40:46 UTC
Created attachment 2692 [details]
smb.conf.txt
Comment 2 Gerald (Jerry) Carter 2007-05-15 06:57:44 UTC
I cannot reproduce this.  Everything works normally for me.
Comment 3 Gerald (Jerry) Carter 2007-05-15 07:00:45 UTC
I need you to attach a raw network trace captured from 
the client using wireshark (http://www.wireshark.org/).
Thanks.
Comment 4 Patrick Rynhart 2007-05-16 00:06:24 UTC
To reproduce the bug Samba must be registering with a Windows Server 2003 WINS Server

i.e. a line of the form

wins server = 130.123.X.Y

is required in the smb.conf file.

Then, Start -> Run 

\\SERVER_WINS_NAME\Netlogon

results in

\\SERVER_WINS_NAME\netlogon refers to a location that is unavailable. It could be on a hard drive on this computer, or on a network ...

but 

\\SERVER_IP_ADDRESS\Netlogon

and

\\SERVER_DNS_ALIAS\Netlogon

succeed. (Note: SERVER_DNS_ALIAS and SERVER_WINS_NAME differ.)

Note that all other shares are accessible using \\SERVER_WINS_NAME\SHARE_NAME except Netlogon. ping SERVER_WINS_NAME and ping SERVER_DNS_ALIAS resolve to SERVER_IP_ADDRESS.

I can confirm that this affects 3.0.25 but does not affect 3.0.23d. 

(I am swapping between two VM Images which are identical apart from one having Samba 3.0.23d and the other having Samba 3.0.25. In both cases Samba is built from Source.)
Comment 5 Patrick Rynhart 2007-05-16 00:17:12 UTC
Created attachment 2694 [details]
updated smb.conf file

wins server =

was removed from my earlier smb.conf file to protect the IP address of our WINS Server. However, I now realise that this necessary for this bug report. (The IP address has been modified however :-)
Comment 6 Patrick Rynhart 2007-05-16 01:47:24 UTC
Note that the Windows XP clients need also to be configured to use the Windows Server 2003 WINS Server for WINS name resolution. In our environment this is set via DHCP.
Comment 7 Patrick Rynhart 2007-05-16 18:17:28 UTC
NB: In our production environment, the Samba Server, the W2K3 WINS Server and the XP Clients are (all) on different subnets.
Comment 8 Gerald (Jerry) Carter 2007-05-16 22:06:40 UTC
Did you reboot the clients after upgrading the server?  Note that
the default for "msdfs root" was changed (as described in the release
notes) and this requires a reboot of the client to pick up the change.
Comment 9 Patrick Rynhart 2007-05-17 00:50:03 UTC
Hi Jerry,

Good catch! I can confirm that the problem is resolved by rebooting clients in between the upgrade of Samba.

I wasn't aware of the "msdfs root" change. 

What will be the affect of setting "msdfs root = yes" in smb.conf ? We don't currently have Vista deployed.

Regards,

Patrick

Comment 10 Patrick Rynhart 2007-05-17 00:51:12 UTC
This is not a bug, but a change to "msdfs root" that requires a reboot of XP clients and Windows Member Servers.

Thank you Jerry.
Comment 11 Gerald (Jerry) Carter 2007-05-22 07:16:19 UTC
reopen and close as a dup
Comment 12 Gerald (Jerry) Carter 2007-05-22 07:16:40 UTC
dup

*** This bug has been marked as a duplicate of 4619 ***