Bug 4570 - Samba 3 does not Support LLMNR
Samba 3 does not Support LLMNR
Status: RESOLVED DUPLICATE of bug 4545
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.25
All All
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 09:44 UTC by David Holder
Modified: 2013-07-17 21:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Holder 2007-04-28 09:44:34 UTC
+++ This bug was initially created as a clone of Bug #4545 +++

Samba3 does not support Link-local Multicast Name Resolution as defined in RFC 4795. Vista and Longhorn both use LLMNR for duplicate name detection and for name resolution in networks with and without other name resolution mechanisms (i.e. DNS). 
A overview of name resolution with LLMNR can be found at http://www.microsoft.com/technet/community/columns/cableguy/cg1106.mspx#EME.
Vista and Longhorn use this to resolve unqualified names and names ending in .local.
LLMNR can be observed on the wire when using Vista and Longhorn, during boots and when resolving a name (e.g. when mapping a share if the host does not have DNS configured).
LLMNR should be implemented in IPv4 and in IPv6.
Let me know if I can help. I can produce traces and test any attempts at an implementation.
Comment 1 Björn Jacke 2013-07-17 21:10:17 UTC

*** This bug has been marked as a duplicate of bug 4545 ***