Bug 4540 - swat does not find password.
swat does not find password.
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
3.0.24
Alpha OSF/1
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 07:18 UTC by Emilio Gargiulo
Modified: 2013-09-02 12:51 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emilio Gargiulo 2007-04-24 07:18:27 UTC
I compile samba on tru64 Unix v5.1b.
All seems work fine, but swat does not authenticate.

This in log.swat:


[2007/04/24 13:50:26, 4] auth/pass_check.c:(631)
  pass_check: Checking password for user root (l=9)
[2007/04/24 13:50:26, 5] auth/pass_check.c:(692)
  Checking password for user root in OSF1_ENH_SEC
[2007/04/24 13:50:26, 2] auth/pass_check.c:(724)
  Disallowing root with null password


In seems that tru64 with basic security (password in /etc/passwd) does not work.
Comment 1 Emilio Gargiulo 2007-04-24 08:50:05 UTC
I find a workaround:
I converted the OS security from  BASE to ENHANCED with the command:
/usr/sbin/convuser -a
and swat will work fine.
But if i return to BASE security model swat still don't work.
Comment 2 Emilio Gargiulo 2007-04-24 09:01:52 UTC
Also, if i change the root password from shell with passwd, then swat does not authenticate too, even if i stay in ENHANCED mode.
So the workaround is not so good.
Comment 3 Björn Jacke 2013-09-02 12:51:49 UTC
swat is removed with 4.1