Bug 447 - make fails
make fails
Status: RESOLVED WONTFIX
Product: Samba 2.2
Classification: Unclassified
Component: libsmbclient
2.2.8a
Other AIX
: P1 regression
: ---
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-12 15:00 UTC by Stephen Spencer
Modified: 2004-02-17 08:45 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Spencer 2003-09-12 15:00:44 UTC
Trying to build SAMBA 2.2.8a on AIX 5.2, using IBM's C v6.0 compiler results in 
the error:
Linking bin/smbd
ld: 0711-317 ERROR: Undefined symbol: .SAFE_FREE
ld: 0711-317 ERROR: Undefined symbol: .VA_COPY
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more
information.
make: 1254-004 The error code from the last command is 8

Upon investigation I discovered that the problem is with snprintf.c -
whenever HAVE_PRINTF, HAVE_VSNPRINTF and HAVE_C99_VSNPRINTF are all defined (as 
they are in my environment) then the SAFE_FREE and VA_COPY macros never get 
defined, even though they are used later on in the code (e.g. vasprintf 
procedure). It may be that the #endif prior to the vasprintf procedure 
specification is misplaced.

I just ran a normal configuration with no options set.
Comment 1 Gerald (Jerry) Carter 2004-02-17 08:45:40 UTC
Sorry, but the 2.2 is not under development any longer.
If you can reproduce this bug against the latest 3.0 release, 
please reopen this bug and change the version in the report.
Thanks.