Bug 4456 - Samba fail to start
Samba fail to start
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
3.0.24
PPC AIX
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-19 18:04 UTC by Marcus Leung
Modified: 2007-04-03 23:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Leung 2007-03-19 18:04:25 UTC
0. AIX system is running AIX 5.2 TL08
1. System installed with 3.0.4 from Bull.  Smbd under some situation runs 100% CPU time;
2. Upgrade to 3.0.24 download from Samba Org.
3. Get following error
   exec(): 0509-036 Cannot load program /usr/local/samba/sbin/nmbd because of the following errors:
        0509-150   Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
        0509-152   Member libiconv.so.2 is not found in archive
4. Follow suggested action by using "unset LIBPATH"
5. No more above message but have following under $Samba_HOME/var/log.nmbd

[2007/03/19 18:22:29, 0] nmbd/nmbd.c:main(699)
  Netbios nameserver version 3.0.24 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2006
[2007/03/19 18:22:29, 0] lib/util_sock.c:open_socket_in(830)
  bind failed on port 137 socket_addr = 0.0.0.0.

6. We used to start nmbd/smbd/swat from /etc/inetd.conf rather than scripts.  How can it work under this setting (cannot unset LIBPATH)

Please help.  Security is domain.

thks,

Marcus.
Comment 1 William Jojo 2007-03-21 13:50:08 UTC
for 5., these packages install into /opt/pware/samba, not /usr/local. Are you symlinking? For the error in log.nmbd, was the old nmbd still running? That would explain the binding failure.

(In reply to comment #0)
> 6. We used to start nmbd/smbd/swat from /etc/inetd.conf rather than scripts. 
> How can it work under this setting (cannot unset LIBPATH)
> Please help.  Security is domain.
> thks,
> Marcus.

It can't unless you can modify /etc/environment to have an appropriate LIBPATH. The problem is you are conflicting with IBM's libiconv which is not enough to run Samba and so you rely on libiconv 1.9.x.

I might be wrong here, but I think lauching [n|s]mbd via inetd was once "bad" since they are long lived process design. But, perhaps that's just a pocketful.

I recommend you script these at startup.

Cheers,

Bill
Comment 2 Marcus Leung 2007-03-21 21:17:29 UTC
Get the email on fixing nmbd/smbd start up. It is working right now using script to start nmbd/smbd.

However, how to start 'swat' not going through inetd as stated on README. No way to do the "unset LIBPATH"
Comment 3 William Jojo 2007-03-22 08:24:28 UTC
(In reply to comment #2)
> Get the email on fixing nmbd/smbd start up. It is working right now using
> script to start nmbd/smbd.
> However, how to start 'swat' not going through inetd as stated on README. No
> way to do the "unset LIBPATH"

Are you sure that's the problem? Go to ftp://ftp.hvcc.edu/pub/pware/aix52 and get the 3.0.24 there. I accidentally configured the Samba site one with PAM. I think that's your SWAT problem.

Cheers,

Bill
Comment 4 Marcus Leung 2007-03-23 00:12:27 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Get the email on fixing nmbd/smbd start up. It is working right now using
> > script to start nmbd/smbd.
> > However, how to start 'swat' not going through inetd as stated on README. No
> > way to do the "unset LIBPATH"
> Are you sure that's the problem? Go to ftp://ftp.hvcc.edu/pub/pware/aix52 and
> get the 3.0.24 there. I accidentally configured the Samba site one with PAM. I
> think that's your SWAT problem.
> Cheers,
> Bill

1. Download and install 3.0.24 from your ftp site;
2. nmbd/smbd starts OK using scripting with "unset LIBPATH"
3. In the browser http://{server}:901
4. Display message cause by libiconv
exec(): 0509-036 Cannot load program swat because of the following errors:
	0509-150   Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
	0509-152   Member libiconv.so.2 is not found in archive 

Comment 5 Gerald (Jerry) Carter 2007-04-03 23:29:19 UTC
AIX Packaging issue.  Bill says go ahead and close.