Bug 4424 - net rpc shutdown does not power of windows 2000 machines
net rpc shutdown does not power of windows 2000 machines
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: net utility
3.0.24
Other Linux
: P3 normal
: none
Assigned To: Jim McDonough
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-02 09:32 UTC by Andreas Meisinger
Modified: 2007-03-02 18:46 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Meisinger 2007-03-02 09:32:44 UTC
net rpc shutdown doesn not power off windows 2000 machines that do power of when asking for power off by windows shutdown

calling shutdown with net rpc leads to the "your system can be safly powered of now" screen
Comment 1 Jim McDonough 2007-03-02 10:41:59 UTC
For starters, which win2k are you using?  Also, are you using the _exact same_ user logged on locally and remotely?

There's no option on the wire for "poweroff" or "don't poweroff" that I'm aware of.  Typically this is controlled via registry settings, and bios can be an issue here.

I should mention that it works for me with win2k pro, using the same user locally and remotely.
Comment 2 Andreas Meisinger 2007-03-02 11:09:34 UTC
I'm using windows 2000 Professional SP4 with most updates and yes I've tried same users and root on the samba machine system powers of on local shutdown invocation but stays at "its now safe" when calling shutdown via rpc.... I've found some posts with exactly the same problem from 2002 and 2004 and of course the changelogentry for samba 3.0.20 but as that are rather outdated i thought it might be worth another bugreport. I've tried on different machines with both w2k pro a turion laptop and a rather old athlon 1000 with asus a7v mainboard both the same problem.

I know that there is no samba option to poweroff but in those posts I read that there IS an option in windows tools for shutdown and poweroff ... first one acting like samba shutdown second one really powering of the machine
Comment 3 Andreas Meisinger 2007-03-02 11:45:25 UTC
I've done further investigations trying several windows utilitys. Using "shutdown.exe" from w2k server resource kit I get the same problem as with samba. Using "psshutdown.exe" from sysinternals with -k switch powers off the machine as desired. Probably ther was added a flag or switch forcing power down via rpc after the initial release of w2k?
Comment 4 Jim McDonough 2007-03-02 16:28:43 UTC
Actually, I sniffed this utility, and it remotely copies a .exe in, installs it as a service, starts the service, then talks to that service over its own pipe.  Ther e is still no RPC in windows that will do this.

It's pretty unlikely that we're gonna inject a new service into someone else's system...I'd suggest you look into the various registry settings as well...

Comment 5 Andreas Meisinger 2007-03-02 16:52:16 UTC
meaning windows rpc shutdown call is actually useless in some cases ... i understand that isn't a samba bug but it's a real pain in the as when needing ability to shut down client pc's remotely.

Thx for your time anyway 
Comment 6 Jim McDonough 2007-03-02 18:46:18 UTC
Yah, i still think you should just quickly explore the registry settings involved.  THe other possibility is that if you want to install those services yourself, an enhancement could be to connect to the Pstools pipe...