Bug 4419 - "delete user from group script" is called with user name instead of group name
"delete user from group script" is called with user name instead of group name
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.24
x86 Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-28 17:54 UTC by Arno van Wouwe
Modified: 2009-06-11 18:13 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arno van Wouwe 2007-02-28 17:54:10 UTC
It is possible to configure a "delete user from group script", using %u for user and %g for the group. When doing a "net rpc group delmem" or manipulating via NT User Manager, the operation fails and the logfile shows that the %g is replaced with the username on invocation time (instead of group name).

Feb 28 16:35:50 localhost smbd[4898]:   smb_delete_user_group: Running the command `/usr/bin/gpasswd -d "root" "root"' gave 1
Comment 1 Guenther Deschner 2009-06-11 18:13:46 UTC
Cannot reproduce this, sorry.