Bug 4414 - MS VISTA cannot login into SMB share
MS VISTA cannot login into SMB share
Status: RESOLVED DUPLICATE of bug 4365
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.24
x64 Windows XP
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-26 08:45 UTC by Bartlomiej Solarz-Niesluchowski
Modified: 2007-03-09 02:27 UTC (History)
0 users

See Also:


Attachments
Log level 10 (204.51 KB, application/x-zip-compressed)
2007-02-28 02:27 UTC, Bartlomiej Solarz-Niesluchowski
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bartlomiej Solarz-Niesluchowski 2007-02-26 08:45:27 UTC
Good Morning!

I have setup (about 2 years ago) in my farm of servers samba based on LDAP.

It looks:
Samba PDC based on LDAP with unix users based on NSS_LDAP
and
SAMBA servers with security domain and local unix users

I do not use winbind.

Problem look like that i can not log in (with MS VISTA as client!) into share located on any server (SAMBA PDC or Samba server) - i have in logs:
NT_STATUS_LOGON_FAILURE (i am sure that i put GOOD pair of username and password).

I read bug:
https://bugzilla.samba.org/show_bug.cgi?id=4365

And on my samba PDC start winbind I can login into samba PDC, but i cannot login into samba server.
I think it is BUG because XP prof. works on both type servers without problems...

Best Regards
Comment 1 Gerald (Jerry) Carter 2007-02-26 08:56:31 UTC
Have you applied the patches from http://www.samba.org/samba/patches/ ?
Comment 2 Bartlomiej Solarz-Niesluchowski 2007-02-26 13:02:44 UTC
Not yet - tomorrow morning (in about +12h from now) I apply the patches and retest...
Comment 3 Bartlomiej Solarz-Niesluchowski 2007-02-27 01:45:22 UTC
On the PDC samba server patches helps, but on SAMBA servers with security domain and local unix users IT DO NOT work!

Comment 4 Volker Lendecke 2007-02-27 03:28:48 UTC
Please upload a debug level 10 log of smbd when failing.

Volker
Comment 5 Bartlomiej Solarz-Niesluchowski 2007-02-28 02:27:56 UTC
Created attachment 2313 [details]
Log level 10
Comment 6 Bartlomiej Solarz-Niesluchowski 2007-02-28 02:32:40 UTC
I attached log-level-10 in about middle of there was try to log in as user test.

And I found that if computer with VISTA IS in domain and is logged as domain user you can log in, but if you log into LOCAL user you cannot log in into share!
Comment 7 Volker Lendecke 2007-03-06 14:51:09 UTC
Could you try the patch in bug 4365? I suspect it might be the same bug.

Volker
Comment 8 Bartlomiej Solarz-Niesluchowski 2007-03-09 02:27:24 UTC
Yes it is the same BUG after patching VISTA connect to share....


*** This bug has been marked as a duplicate of 4365 ***