Bug 4411 - RSYNC connection hangs: writefd_unbuffered failed to write 4092 bytes
RSYNC connection hangs: writefd_unbuffered failed to write 4092 bytes
Status: RESOLVED INVALID
Product: rsync
Classification: Unclassified
Component: core
2.5.7
All Linux
: P3 critical
: ---
Assigned To: Wayne Davison
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-25 04:45 UTC by George Buslovitch
Modified: 2008-05-23 09:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description George Buslovitch 2007-02-25 04:45:00 UTC
I'm running with Red Hat OS
I'm trying to synchronize 2 machines with rsync protocol.

The following rsync command works: 
rsync * -vatcu include="1" qoduser@lab2-pc:/usr/local/imagine/currenBuild/mcs/cache_index_files

After ~150M files transmitted connection closed with some errors :

Received disconnect from 20.20.10.250: 2: Corrupted MAC on input.
rsync: writefd_unbuffered failed to write 4 bytes [sender]: Broken pipe (32)
rsync: connection unexpectedly closed (1862 bytes received so far) [sender]
rsync error: unexplained error (code 255) at io.c(453) [sender=2.6.9]
Comment 1 Matthias Dieter Wallnöfer 2008-05-23 05:06:40 UTC
That seems to be related to rsync.
Comment 2 Wayne Davison 2008-05-23 09:26:43 UTC
You need to investigate the cause of the error that made the connection close:

Received disconnect from 20.20.10.250: 2: Corrupted MAC on input.

If you google for the "corrupted" part of the error, you'll see this is an ssh error.