Bug 4403 - Kernel hangs when using a cifs mount on a multiprocessor opteron server
Kernel hangs when using a cifs mount on a multiprocessor opteron server
Status: RESOLVED FIXED
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
x64 Linux
: P3 regression
: ---
Assigned To: Steve French
https://bugzilla.novell.com/show_bug....
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-18 09:09 UTC by Rosario Lombardo
Modified: 2009-03-07 10:54 UTC (History)
1 user (show)

See Also:


Attachments
Support info e logs (523.35 KB, text/plain)
2007-02-18 09:11 UTC, Rosario Lombardo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rosario Lombardo 2007-02-18 09:09:05 UTC
When working on cifs filesystem on a 4 processor opteron machine with 8gb ram,
opensuse 10.2 32bit, kernel bigsmp, the kernel hangs with the following:

Jan 31 22:03:50 fileserver sshd[5024]: Accepted keyboard-interactive/pam for
rosario from 10.1.10.40 port 57808 ssh2
Jan 31 22:03:59 fileserver su: (to root) rosario on /dev/pts/0
Jan 31 22:04:16 fileserver syslog-ng[3183]: STATS: dropped 0
Jan 31 22:09:27 fileserver su: (to postgres) rosario on /dev/pts/0
Jan 31 22:11:56 fileserver kernel: BUG: unable to handle kernel paging request
at virtual address 80b8e484
Jan 31 22:11:56 fileserver kernel:  printing eip:
Jan 31 22:11:56 fileserver kernel: c0161308
Jan 31 22:11:56 fileserver kernel: *pde = 00000000
Jan 31 22:11:56 fileserver kernel: Oops: 0002 [#1]
Jan 31 22:11:56 fileserver kernel: SMP 
Jan 31 22:11:56 fileserver kernel: last sysfs file:
/firmware/edd/int13_dev81/extensions
Jan 31 22:11:56 fileserver kernel: Modules linked in: nls_utf8 cifs button
battery ac apparmor aamatch_pcre loop dm_mod tg3 r8169 i2c_amd8111 i2c_amd756
ide_cd ohci_hcd cdrom usbcore i2c_core amd_rng parport_pc lp parport ext3
mbcache jbd edd fan sg aacraid amd74xx thermal processor sd_mod scsi_mod
ide_disk ide_core
Jan 31 22:11:56 fileserver kernel: CPU:    3
Jan 31 22:11:56 fileserver kernel: EIP:    0060:[<c0161308>]    Tainted: G    
U VLI
Jan 31 22:11:56 fileserver kernel: EFLAGS: 00010082   (2.6.18.2-34-bigsmp #1) 
Jan 31 22:11:56 fileserver kernel: EIP is at free_block+0x5c/0xed
Jan 31 22:11:56 fileserver kernel: eax: f25fa9e0   ebx: dfffdec0   ecx:
f2a50740   edx: 80b8e480
Jan 31 22:11:56 fileserver kernel: esi: f2703000   edi: dfff9a80   ebp:
dfc8abe0   esp: dff09ef4
Jan 31 22:11:56 fileserver kernel: ds: 007b   es: 007b   ss: 0068
Jan 31 22:11:56 fileserver kernel: Process events/3 (pid: 13, ti=dff08000
task=dff076f0 task.ti=dff08000)
Jan 31 22:11:56 fileserver kernel: Stack: dffcd614 00000005 00000003 dfc8abd4
00000005 dfc8abc0 dfffdec0 c0161411 
Jan 31 22:11:56 fileserver kernel:        00000000 dfff9a80 dfffdec0 dfff9a80
dfc8a7c0 00000286 c016286c 00000000 
Jan 31 22:11:56 fileserver kernel:        00000000 c602bc00 c602bc04 c012f679
ffffffff ffffffff ffffffff c0162819 
Jan 31 22:11:56 fileserver kernel: Call Trace:
Jan 31 22:11:56 fileserver kernel:  [<c0161411>] drain_array+0x78/0x97
Jan 31 22:11:56 fileserver kernel:  [<c016286c>] cache_reap+0x53/0x117
Jan 31 22:11:56 fileserver kernel:  [<c012f679>] run_workqueue+0x83/0xc5
Jan 31 22:11:56 fileserver kernel:  [<c0162819>] cache_reap+0x0/0x117
Jan 31 22:11:56 fileserver kernel:  [<c012ff94>] worker_thread+0xd9/0x10d
Jan 31 22:11:56 fileserver kernel:  [<c011b15f>] default_wake_function+0x0/0xc
Jan 31 22:11:56 fileserver kernel:  [<c01324d4>] kthread+0xec/0x11c
Jan 31 22:11:56 fileserver kernel:  [<c012febb>] worker_thread+0x0/0x10d
Jan 31 22:11:56 fileserver kernel:  [<c01323e8>] kthread+0x0/0x11c
Jan 31 22:11:56 fileserver kernel:  [<c0102005>] kernel_thread_helper+0x5/0xb
Jan 31 22:11:56 fileserver kernel: Code: 8b 02 f6 c4 40 74 03 8b 52 0c 8b 02 84
c0 78 08 0f 0b 60 02 86 81 2c c0 8b 4a 1c 8b 44 24 20 8b 11 8b 9c 87 10 02 00
00 8b 41 04 <89> 42 04 89 10 31 d2 2b 71 0c c7 01 00 01 10 00 c7 41 04 00 02 
Jan 31 22:11:56 fileserver kernel: EIP: [<c0161308>] free_block+0x5c/0xed
SS:ESP 0068:dff09ef4
Comment 1 Rosario Lombardo 2007-02-18 09:11:04 UTC
Created attachment 2296 [details]
Support info e logs
Comment 2 Steve French 2007-03-14 17:18:58 UTC
Have the fixes for the hang fixed in cifs 1.48 (in either current mainline or the cifs-backport-for-old-kernels) been tried on this?
Comment 3 Steve French 2009-03-07 10:54:57 UTC
Should be resolved now - no similar reports, and mount code has been rewritten to avoid various races since this report.