Bug 4392 - nsswitch winbind lib issue
nsswitch winbind lib issue
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.24
Sparc Solaris
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-13 06:47 UTC by Michael Fuchs
Modified: 2007-02-13 07:41 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Fuchs 2007-02-13 06:47:03 UTC
After trying to move from 3.0.11 to 3.0.24 (compiled with winbind option on Solaris9) there seems to be a problem with the winbind nsswitch lib.

Accessing the shares on windows is not possible
'# getent passwd' works fine, wbinfo works as expected.
'# ls -la' on a shared shows only the Unix-User-ID, the winbind log is returning:

Winbind Log:
[2007/02/13 13:30:11, 6] nsswitch/winbindd.c:new_connection(601)
  accepted socket 17
[2007/02/13 13:30:11, 0] nsswitch/winbindd.c:request_len_recv(517)
  request_len_recv: Invalid request size received: 1824
[2007/02/13 13:30:17, 6] nsswitch/winbindd.c:new_connection(601)
  accepted socket 17
[2007/02/13 13:30:17, 0] nsswitch/winbindd.c:request_len_recv(517)
  request_len_recv: Invalid request size received: 1824


I searched on the web, but all I could find was statements about using the wrong nsslib winbind version, which isn't the case here, I removed the old and replaced it with the one from 3.0.24.
Comment 1 Volker Lendecke 2007-02-13 06:57:12 UTC
99.99% this is because you did not copy the libnss_winbind.so to /lib or wherever Solaris expects the nss libs. It might be necessary to re-start all daemons or even reboot the box.

Closing. Please re-open if you copied libnss_winbind.so appropriatedly and the log messages still happens.

Volker
Comment 2 Michael Fuchs 2007-02-13 07:31:47 UTC
I removed the old one and replaced it with the latest one. I also ran a truss to make sure it's accessing the one I replaced. 

It seems it might be another problem, I just completely removed the nss winbind lib. after deletion 'getent passwd' stopped working as expected, but an 'ls -la' on the sharedir still adds the 'request_len_recv: Invalid request size received: 1824' to the winbind log
Comment 3 Volker Lendecke 2007-02-13 07:41:07 UTC
Did you reboot the box? If yes, re-open.

Volker