Bug 4380 - Abort of "make"
Abort of "make"
Product: Samba 3.0
Classification: Unclassified
Component: File Services
Alpha OSF/1
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2007-02-08 07:23 UTC by Manfred Junga
Modified: 2007-02-14 03:40 UTC (History)
0 users

See Also:

config status (70.34 KB, text/plain)
2007-02-08 07:23 UTC, Manfred Junga
no flags Details
output of make (26.40 KB, text/plain)
2007-02-08 07:24 UTC, Manfred Junga
no flags Details
Makefile (64.64 KB, text/plain)
2007-02-08 07:24 UTC, Manfred Junga
no flags Details
makefile.in (67.83 KB, text/plain)
2007-02-08 07:25 UTC, Manfred Junga
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred Junga 2007-02-08 07:23:03 UTC

we tried now to install Samba 3.0-23d on our system

hostname = awkdbserv
uname -m = alpha
uname -r = V4.0
uname -s = OSF1
uname -v = 878

/usr/bin/uname -p = alpha

The step configure worked correct, but we got an error in the step make and
then an abort.

Script started on Thu Feb  8 06:31:23 2007
<awkdbserv>root:/usr2/local/samba3/source # make
Using FLAGS =  -O -D_SAMBA_BUILD_ -I/usr2/local/samba3/source/popt -I/usr2/local/samba3/source/iniparser/src -Iinclude -I/usr2/local/samba3/source/include -I/usr2/local/samba3/source/tdb  -I. -DHAVE_CONFIG_H  -I/usr2/local/samba3/source -D_SAMBA_BUILD_    
      LIBS = -lproplist -lsecurity -lresolv -lresolv
      LDSHFLAGS = -shared 
      LDFLAGS = 
      PIE_CFLAGS = 
      PIE_LDFLAGS = 
Compiling dynconfig.c
cc: Error: include/proto.h, line 1079: In this parameter list, "uint32_t" must either be a type or must be followed by a ",".
struct timeval timeval_set(uint32_t secs, uint32_t usecs);
cc: Error: include/proto.h, line 1084: Ill-formed parameter type list.
			   uint32_t secs, uint32_t usecs);

During the installation, the old version of Samba 1.9 is still running, but I
think this doesn't matter at this installationstep.

Thank you for support


Manfred Junga
Comment 1 Manfred Junga 2007-02-08 07:23:47 UTC
Created attachment 2274 [details]
config status
Comment 2 Manfred Junga 2007-02-08 07:24:12 UTC
Created attachment 2275 [details]
output of make
Comment 3 Manfred Junga 2007-02-08 07:24:34 UTC
Created attachment 2276 [details]
Comment 4 Manfred Junga 2007-02-08 07:25:01 UTC
Created attachment 2277 [details]
Comment 5 Manfred Junga 2007-02-14 03:40:02 UTC
Dear Sirs,

we installed SAMBA Version 2.2.7. . We know, that this version is out of support, but it works without problems and we won't change our OS in the moment to an higher version, to install an Samba version 3.x.

Thank you for help

Manfred Junga