Bug 4367 - libaddns.so, libsmbclient.so, libsmbsharemodes.so, libmsrpc.so linking problem
libaddns.so, libsmbclient.so, libsmbsharemodes.so, libmsrpc.so linking problem
Status: RESOLVED DUPLICATE of bug 4230
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
x86 Linux
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2007-02-03 01:34 UTC by Mikhail Kshevetskiy
Modified: 2007-04-24 23:46 UTC (History)
0 users

See Also:

-fPIC patch (1.45 KB, patch)
2007-02-03 01:38 UTC, Mikhail Kshevetskiy
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Kshevetskiy 2007-02-03 01:34:30 UTC
The -fPIC gcc flags was used to create libaddns.so, libsmbclient.so, libsmbsharemodes.so and libmsrpc.so shared libraries. The result is:
1) ldd fail with error on this libraries
2) you can't use this shared libraies with existing application
3) you can't build an application that use one of this libraries.
Comment 1 Mikhail Kshevetskiy 2007-02-03 01:38:45 UTC
Created attachment 2266 [details]
-fPIC patch

this patch remove exclude $(LDFLAGS) variable from building of libaddns.so, libsmbclient.so, libsmbsharemodes.so and libmsrpc.so, thus -fPIC option is not applied.
Comment 2 Mikhail Kshevetskiy 2007-04-24 23:46:48 UTC

*** This bug has been marked as a duplicate of 4230 ***