Bug 436 - wrong path to popt.h in include/includes.h
wrong path to popt.h in include/includes.h
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0preX
All Solaris
: P3 normal
: none
Assigned To: Tim Potter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-11 04:03 UTC by Thomas Müller
Modified: 2005-11-14 09:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Müller 2003-09-11 04:03:11 UTC
I tried to compile rc3 on Solaris 8 and I received the following error:

compiling dynconfig.c
In file included from dynconfig.c:21
include/includes.h:843:18: popt.h: No such file or directory

In includes.h there is the entry 
"include "popt.h" but popt.h is in popt/popt.h

I have modified includes.h to the right path and now I can compile rc3.

Please change it in includes.h

Thomas
Comment 1 Tim Potter 2003-09-11 17:53:45 UTC
Thomas, did your system detect an installed version of popt when running
configure?  I am guessing that configure detected libpopt but there is no popt.h
header file installed.  You can also try compiling with --with-included-popt.

Changing component to build environment, reassigning to me.
Comment 2 Gerald (Jerry) Carter 2003-09-19 11:44:59 UTC
From email....

> Ok, if I run configure --with-included-popt 
> --with-acl-support and then start make, everything works 
> fine with the original includes.h.  The "bug-report" is based 
> on configure --with-acl-support, which I always used in 
> the past (2.2.x) and always leeded me to a succusfull build 
> of Samba.  Ok,  obviously it si not a bug in Samba, sorry.
>
> Btw, you are doing a great job with Samba, go on like this.
>
> Thomas 
Comment 3 Gerald (Jerry) Carter 2005-02-07 09:05:56 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 4 Gerald (Jerry) Carter 2005-11-14 09:30:53 UTC
database cleanup