Bug 4323 - smbpasswd was unabled to set initial password against windows PDC
smbpasswd was unabled to set initial password against windows PDC
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.9
Other Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 10:05 UTC by Derek
Modified: 2007-01-16 00:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Derek 2007-01-04 10:05:57 UTC
PDC was running on a separate subnet, but routed appropriately.
smbclient was returning NT_STATUS_PASSWORD_MUST_CHANGE so I tried:
smbpasswd -r 192.168.1.5 -U myusername 

I would authenticate successfully (got a different error if I didn't), but every time smbpasswd would return 
NT_STATUS_ACCESS_DENIED.
I carelessly neglected to preserve running -D,
and once I changed initial password using an RDP connection to a windows machine on the domain, all future smbpasswd calls worked fine.
Comment 1 Derek 2007-01-04 13:47:28 UTC
Oh, was using 3.0.22 - updating to 3.0.23d solved another problem with smbmount, so perhaps they are related.
If I get an opportunity to retest this, and it works with 3.0.23d, I'll close this out.
Comment 2 Volker Lendecke 2007-01-16 00:50:32 UTC
Closing, feel free to re-open if 3.0.23 does not solve it. If you still got problems, please attach a sniff of the attempt.

Volker