Bug 4287 - trying to use mount.cifs
trying to use mount.cifs
Status: RESOLVED INVALID
Product: CifsVFS
Classification: Unclassified
Component: user space tools
2.6
Other Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-08 03:33 UTC by Marek Must
Modified: 2012-04-06 10:53 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Must 2006-12-08 03:33:39 UTC
trying to use 

mount.cifs //192.168.1.22/marek /home/marek/smb -o username=marek

asks my password nicely and it does it oky.. and works also.. BUT.

it shows owner and group in numbers (id)

[root@localhost marek]# ls -la |grep samba
drwxrwxrwx  2  1004  1005       0 nov   21 14:53 samba/
[root@localhost marek]#                                

something like this... not sure if this is a bug or what... i thought i post it:)
Comment 1 Marek Must 2006-12-08 03:39:51 UTC
if my the servers and pcs uid fall together then its oky.. and samba resolves it nicely.. but if they are diffrent, then we have problem and it doesent do what it should do.. and mount it and but group and owner right names not numbers..
Comment 2 Marek Must 2006-12-08 03:40:54 UTC
trying to use 

mount.cifs //192.168.1.22/marek /home/marek/smb -o username=marek

asks my password nicely and it does it oky.. and works also.. BUT.

it shows owner and group in numbers (id)

[root@localhost marek]# ls -la |grep samba
drwxrwxrwx  2  1004  1005       0 nov   21 14:53 samba/
[root@localhost marek]#                                

something like this... not sure if this is a bug or what... i thought i post
it:)





if my the servers and pcs uid fall together then its oky.. and samba resolves it nicely.. but if they are diffrent, then we have problem and it doesent do what it should do.. and mount it and but group and owner right names not numbers..
Comment 3 Shirish S. Pargaonkar 2009-07-22 13:06:03 UTC
This is not a bug but limitation.  Right now, cifs can't translate the
uids and gids to user names and group names respectively if there is no
mapping in /etc/passwd and /etc/group respectively.

Comment 4 Shirish S. Pargaonkar 2010-01-05 18:09:26 UTC
Do you have a /etc/nsswitch.conf file and if so, what entries do you have for 
passwd and group in that file?
Is there a username in /etc/passwd for uid 1004 or a groupname for gid 1005
in /etc/group?  
Comment 5 Shirish S. Pargaonkar 2010-01-07 10:56:36 UTC
This is not a bug, it is lack of availibility of mapping uids and gids. 
If you think otherwise, please comment. Otherwise plan on closing this bug in
a month's time.
Comment 6 Jeff Layton 2010-01-14 07:20:38 UTC
Agreed. Not a bug, but just how this works since we don't have any way to map uid's and gid's on the server to those on the client.

Comment 7 Jeff Layton 2010-01-14 07:28:30 UTC
FWIW, this is very similar to how NFSv2/3 work when uid's and gid's are mismatched between client and server. In this situation you may want to consider mounting with -o noperm to disable client-side permission checking and leave permissions up to the server.
Comment 8 Luk Claes 2010-09-18 12:56:22 UTC
Since everyone agrees, it's not a bug, can someone mark it as invalid (resolved)?
Comment 9 Jeff Layton 2012-04-06 10:53:48 UTC
Done! Sorry for the delay!