Bug 4232 - rsync error: timeout in data send/receive (code 30) at io.c(165) [sender=3.0.0cvs]
rsync error: timeout in data send/receive (code 30) at io.c(165) [sender=3.0....
Product: rsync
Classification: Unclassified
Component: core
x86 Linux
: P3 minor
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2006-11-15 15:00 UTC by william mcinnis
Modified: 2010-08-21 13:12 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description william mcinnis 2006-11-15 15:00:07 UTC
ok this applys to all versions of rsync

just at certin times i will get 

rsync error: timeout in data send/receive (code 30) at io.c(165) 
and then thats it 

this is a local network i ran netstat when it does this and they say

tcp        1      0         fpserv.dulug.duke.edu:http  
tcp        1      0         fpserv.dulug.duke.edu:http  
tcp        0 188104          clients:rsync               
tcp        0      0 ::ffff:    ::ffff:  
tcp        0      0 ::ffff:    ::ffff:  

tcp    72300  63800          

iam backing up about 25 to 50 gigs of stuff per computer 

and it will just thow the error at random spots i have changed switches sata cards motherboards all still have the same issue and i also change network cards 
i have installed build 28 build 29 and build 30 all give me the same error except the version line tag is different per version
Comment 1 Wayne Davison 2006-11-15 19:00:46 UTC
You haven't explained how this is not due to your configuring the timeout wrong.  You should also mention what options you're using.  For instance, using --delete-during is much better when using a timeout than using --delete (which defaults to --delete-before, and results in a lot of dead time on the socket).
Comment 2 william mcinnis 2006-11-16 00:33:45 UTC
ok here is my config as per the email i sent you 
[wmcinnis@clients ~]$ sudo cat /etc/rsyncd.conf 

ignore nonreadable = yes

log file = /var/log/rsyncd.log

log format = %o %h [%a] %m (%u) %f %l %b %c

transfer logging = true

read only = true

lock file = /var/run/rsyncd.lock

hosts allow =,,,,,,,,,,

max connections = 5

uid = root

gid = root

auth users = root

secrets file = /etc/rsyncd.secrets


        list = true

        path = /var/www

        comment = Comment : var/www


        list = true

        path = /

        comment = comment : / partition


        list = true

        path = /home/shared

        comment = Comment : programmers shared


        list = true

        path = /var/log

        comment = Comment : Logs


        list= true

        path= /etc

        comment = Comment : etc





and personal backup says 


full backup started for directory www
Connected to clients:873, remote version 30
Negotiated protocol version 28
Connected to module www
Sending args: --server --sender --numeric-ids --perms --owner --group -D --links --times --recursive --ignore-times . .

i have added timeout = 600 on both the client and server and same issue
Comment 3 william mcinnis 2006-11-16 00:37:42 UTC
and just now i have tried timeout = 0 on both ends
Comment 4 william mcinnis 2006-11-16 00:46:22 UTC
same results
Comment 5 Rudy 2007-05-25 05:44:59 UTC
I was able to replicate this error.
I use rsync to mirror "Project Gutenberg" from "ibiblio.org". That is about 245GB of data in about 358'000 files. Since about one week i got the following error:
"timeout in data send/receive (code 30) at io.c(165)" 
It also indicated that i used version 2.6.8 and ibiblio used 2.6.9. 
 - Upgraded to 2.6.9
 - Still the same error.
I used "rsync -avHS --delete --progress remote.place local.place"
started reading the FAQ and then this bug list
The option "--delete-during" solved the problem!
Comment 6 Wayne Davison 2010-08-21 13:12:05 UTC
The timeout code in 3.1.0dev is much improved over 2.x and 3.0.x.  Hopefully this will fix the issue you were seeing.