Bug 4219 - MS-DOS Scrambled filenames containing '@' and '#' like chars using MS-CLIENT
MS-DOS Scrambled filenames containing '@' and '#' like chars using MS-CLIENT
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: libsmbclient
3.0.22
x86 Other
: P3 normal
: none
Assigned To: Derrell Lipman
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-11 07:40 UTC by Dirk Teurlings
Modified: 2006-12-04 16:36 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Teurlings 2006-11-11 07:40:35 UTC
Gentoo-linux: 2006.1
Samba: samba-3.0.22-r3 (also samba-3.0.23a)

Under MS-DOS with MS-CLIENT we use filenames containing an @. This is de default space replacement in Siemens STEP5.
 
From Dos->Linux the conversion of filenames works perfectly, the files are properly diplayed on the filesystem as on other windows 2k/XP systems. 

However, from Linux->Dos the conversion doesn't work properly, whenever there's a character like @ of # dos scrambles up almost the entire filename. At this moment, it looks like the first character of the filename states correct, but every following character is not likely to be one of the characters which it should be. Even when a file is only two characters long, if one of them is an @ the filename gets way too long and samba mangle it to an even more unreadable filename. I've tried several settings like charsets and dos filename attributes etc. 

example:

winxp
linux -> dos
h@       hp1q68~5

I've located a bug report, https://bugzilla.samba.org/show_bug.cgi?id=1521 which state is still new, that could be the sollution. However, it's not for the same version so I'm trying to tweak it. I've also considered this could be a problem with MS-CLIENT. But before samba we used a windows NT server machine that didn't have this problem.

As well as on Dos as on Linux there are no logfile entries
Comment 1 Dirk Teurlings 2006-12-04 16:36:56 UTC
I'm not sure I read the man-pages correctly, after setting the "mangling name" option to "no", everything worked liked a charm...