Bug 4186 - apt-get build fails to build .deb package
apt-get build fails to build .deb package
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.23c
PA-RISC Linux
: P3 critical
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 02:05 UTC by emilio
Modified: 2009-12-11 08:34 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description emilio 2006-10-24 02:05:17 UTC
Trying to install from http://us4.samba.org/samba/ftp/Binary_Packages/Debian/dists/sarge/samba
and get this error message:

----------------
sudo apt-build build-source samba
...
...
...
Building the following packages from source:
libpam-smbpass
swat
winbind
smbfs
samba-dbg
smbclient
python2.3-samba
samba
libsmbclient
samba-common
libsmbclient-dev
samba-doc
-----> Installing build dependencies (for samba) <-----
Reading Package Lists... Done
Building Dependency Tree... Done
E: Build-dependencies for samba could not be satisfied.
-----> Downloading samba source (samba 3.0.23c-1) <-----
-----> Updating package lists <-----
Hit http://cvs.parisc-linux.org ./ Packages
Ign http://cvs.parisc-linux.org ./ Release
...
...
...
Reading Package Lists... Done
Reading Package Lists... Done
Building Dependency Tree... Done
Need to get 17.8MB of source archives.
Get:1 http://us1.samba.org sarge/samba samba 3.0.23c-1 (dsc) [820B]
Get:2 http://us1.samba.org sarge/samba samba 3.0.23c-1 (tar) [17.7MB]
Get:3 http://us1.samba.org sarge/samba samba 3.0.23c-1 (diff) [112kB]
Fetched 3B in 5s (1B/s)
Skipping unpack of already unpacked source in samba-3.0.23c
-----> Building samba <-----
E: Unable to find a source package for samba
Use of uninitialized value in concatenation (.) or string at /usr/bin/apt-build line 301.
Can't chdir(samba-): No such file or directory at (eval 1) line 3
        main::__ANON__('samba-') called at /usr/bin/apt-build line 301
        main::build('samba', '3.0.23c', -1) called at /usr/bin/apt-build line 563
        main::build_source called at /usr/bin/apt-build line 81
Comment 1 Karolin Seeger 2009-12-11 08:34:00 UTC
I think the upstream Debian packages are no longer maintained (3.0.26a-1 is pretty old).
Please use Samba packages from Debian.
Closing out bug report.

Thanks!