Bug 4169 - Mac OS X (intel) 10.4.8 smbclient null pointer dereference
Mac OS X (intel) 10.4.8 smbclient null pointer dereference
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.23c
Other Mac OS X
: P3 major
: none
Assigned To: James Peach
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 16:17 UTC by Dan Campbell
Modified: 2007-09-26 22:25 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Campbell 2006-10-12 16:17:55 UTC
smblient dump

Here is what I got:
(gdb) run -U administrator%"MYPASS" -I 10.1.0.11 -L 10.2.0.9
Starting program: /usr/bin/smbclient -U administrator%"MYPASS" -I
10.1.0.11 -L 10.2.0.9
Reading symbols for shared libraries ..... done
Domain=[MY_DOMAIN] OS=[Unix] Server=[Samba 3.0.23c]

        Sharename       Type      Comment
        ---------       ----      -------

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000000
0x000a11fd in rpccli_srvsvc_NetShareEnum ()
Comment 1 Spammer 2007-04-28 04:11:44 UTC
Created attachment 2497
Comment 2 James Peach 2007-05-19 00:36:06 UTC
Is this reproducible?
Comment 3 James Peach 2007-09-26 22:25:41 UTC
Unable to reproduce. I've seen a couple of reports of this on 10.4, but not in 10.5.