Bug 4166 - smb.conf: socket address without 0.0.0.0 misses broadcasts
smb.conf: socket address without 0.0.0.0 misses broadcasts
Status: RESOLVED DUPLICATE of bug 7118
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.23c
All All
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 07:55 UTC by Robert Dahlem
Modified: 2010-02-08 17:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Dahlem 2006-10-11 07:55:43 UTC
Tested on Linux 2.6.17.4 x86_64, but assuming this is not platform or OS specfic.

I configured "socket adress = 192.168.1.2" (like I used to in Samba 2) and wondered, why nmbd no longer answers to broadcasts. Additional symptom is that "netstat -an | grep :137" finds "192.168.1.2:137" but not "0.0.0.0:137".

Solution was to configure "socket address = 192.168.1.2 0.0.0.0"

This might be the opposite of bug #3500.

This might be intentionally. In this case it should be documented.
Comment 1 Jeremy Allison 2010-02-08 17:30:47 UTC

*** This bug has been marked as a duplicate of bug 7118 ***