Bug 4161 - Crash winbindd in name_deadbeef
Crash winbindd in name_deadbeef
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.23c
x86 Linux
: P3 major
: none
Assigned To: Guenther Deschner
Samba QA Contact
http://www.samotlor.info
:
: 4304 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 22:34 UTC by Evgeny Kurensky
Modified: 2011-05-11 11:42 UTC (History)
3 users (show)

See Also:


Attachments
Core dump (129.66 KB, application/octet-stream)
2006-11-23 11:09 UTC, Guido Leenders
no flags Details
Core dump of winbindd (131.83 KB, application/gzip)
2006-12-18 04:29 UTC, Guido Leenders
no flags Details
Core dump (131.83 KB, application/x-gzip)
2007-02-24 07:28 UTC, Guido Leenders
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Evgeny Kurensky 2006-10-10 22:34:46 UTC
Hi!
Winbindd core dumped with:

  ===============================================================
[2006/10/11 02:01:00, 0] lib/fault.c:fault_report(42)
  INTERNAL ERROR: Signal 6 in pid 3397 (3.0.23c)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2006/10/11 02:01:00, 0] lib/fault.c:fault_report(44)
                                                                                                                                                             
  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2006/10/11 02:01:00, 0] lib/fault.c:fault_report(45)
  ===============================================================
[2006/10/11 02:01:00, 0] lib/util.c:smb_panic(1592)
  PANIC (pid 3397): internal error
[2006/10/11 02:01:00, 0] lib/util.c:log_stack_trace(1699)
  BACKTRACE: 26 stack frames:
   #0 winbindd(log_stack_trace+0x2d) [0xa1a5dd]
   #1 winbindd(smb_panic+0x75) [0xa1a485]
   #2 winbindd [0xa05766]
   #3 /lib/tls/libc.so.6 [0x1c1eb8]
   #4 /lib/tls/libc.so.6(abort+0x1d5) [0x1c34e5]
   #5 winbindd [0xa414e2]
   #6 winbindd [0xa41765]
   #7 winbindd(cli_krb5_get_ticket+0x242) [0xa41c42]
   #8 winbindd(spnego_gen_negTokenTarg+0x62) [0xa437d2]
   #9 winbindd [0xb04682]
   #10 winbindd [0xb049ae]
   #11 winbindd(ads_sasl_bind+0x150) [0xb052a0]
   #12 winbindd(ads_connect+0x1ea) [0xafe12a]
   #13 winbindd [0xb0b06a]
   #14 winbindd(ads_do_search_retry+0x46) [0xb0b356]
   #15 winbindd(ads_search_retry+0x3f) [0xb0b40f]
   #16 winbindd [0x9b7a64]
   #17 winbindd [0x9a2419]
   #18 winbindd [0x99718e]
   #19 winbindd(winbindd_getgrgid+0x2ba) [0x9981ba]
   #20 winbindd [0x992e77]
   #21 winbindd [0x9930b8]
   #22 winbindd [0x99433a]
   #23 winbindd(main+0x5c5) [0x994945]
   #24 /lib/tls/libc.so.6(__libc_start_main+0xda) [0x1af78a]
   #25 winbindd [0x992732]
[2006/10/11 02:01:01, 0] lib/fault.c:dump_core(173)
  dumping core in /var/log/samba/cores/winbindd

System config:
Linux laz 2.4.21-37.ELsmp #1 SMP Wed Sep 7 13:28:55 EDT 2005 i686 i686 i386 GNU/Linux

Samba Version 3.0.23c

Compile option with RHEL standart packaging:
rpm -qa |grep samba

samba-debuginfo-3.0.23c-4
samba-common-3.0.23c-4
samba-3.0.23c-4
samba-swat-3.0.23c-4
samba-client-3.0.23c-4
samba-doc-3.0.23c-4

Kerberos:
rpm -qa |grep krb

krbafs-utils-1.1.1-11
krb5-libs-1.2.7-47
pam_krb5-1.75-1
krb5-workstation-1.2.7-47
krbafs-1.1.1-11
krb5-server-1.2.7-47
krbafs-devel-1.1.1-11
krb5-devel-1.2.7-47

Smb config - global section:

[global]
        workgroup = SAMOTLOR
        realm = SAMOTLOR.NIPS.RU
        server string = Laz Samba Server
        interfaces = eth0, 127.0.0.1
        bind interfaces only = Yes
        security = ADS
        log file = /var/log/samba/log.smbd
        max log size = 500
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        load printers = No
        printcap name = /etc/printcap
        show add printer wizard = No
        os level = 33
        preferred master = No
        local master = No
        domain master = No
        dns proxy = No
        idmap uid = 10000-20000
        idmap gid = 10000-20000
        template homedir = /home/%U
        template shell = /bin/bash
        winbind cache time = 10
        password server = BASE


GDB output:
gdb /usr/sbin/winbindd /var/log/samba/cores/winbindd/core.3397
GNU gdb Red Hat Linux (6.3.0.0-0.30.1rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db library "/lib/tls/libthread_db.so.1".
 
Core was generated by `winbindd'.
Program terminated with signal 6, Aborted.
#0  0x001c1cdf in name_deadbeef ()
(gdb) bt
#0  0x001c1cdf in name_deadbeef ()
#1  0x00207a5d in dyn_CONFIGFILE ()
#2  0x002ce898 in ?? ()
#3  0x00000000 in ?? ()
(gdb)
Comment 1 Guido Leenders 2006-11-23 11:09:53 UTC
Created attachment 2232 [details]
Core dump
Comment 2 Guido Leenders 2006-11-23 11:14:17 UTC
Seem to have the same problem.
Running on SLES 9.
Upgraded from default installed 3.0.4 to 3.0.23d. Samba package and setup was only component changed.

Infrastructure:
Samba on fileserver SLES9, connecting to Active Directory server W2003.

Setup was changed when going to 3.0.23 from security=domain to ads. Following guidelines and succesfully connected through kerberos.

Winbind crashes sometimes within minutes after a restart, sometimes it takes hours.

Core info (also attached):
Core was generated by `/usr/sbin/winbindd -s /etc/samba/smb.conf'.
Program terminated with signal 6, Aborted.

Smb.conf excl services:
# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SuSE
# Date: 2005-01-28
[global]
        wide links = yes
        follow symlinks = yes
        workgroup = ACME
        realm = ACME.LOCAL
        security = ADS
        os level = 1
        server string = Samba 3023d
        unix extensions = yes
        encrypt passwords = yes
        map to guest = Bad User
        printing = CUPS
        printcap name = CUPS
        socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
        wins support = No
        veto files = /*.eml/*.nws/riched20.dll/*.{*}/
        syslog = 1
        syslog only = no
        log level = 1
        password server = WS08.ACME.LOCAL
        disable spoolss=yes
        show add printer wizard=no
        idmap uid=15000-20000
        idmap gid=15000-20000
        winbind use default domain=yes
        winbind separator=+
        template shell=/bin/ksh
        template homedir=/home/%D/%U
        max log size = 0
        winbind enum users=yes
        winbind enum groups=yes

log.wb-BUILTIN:
[2006/11/23 18:01:03, 4] nsswitch/winbindd_dual.c:fork_domain_child(913)
  child daemon request 54
[2006/11/23 18:01:03, 3] nsswitch/winbindd_async.c:winbindd_dual_getsidaliases(950)
  [ 4640]: getsidaliases
[2006/11/23 18:01:03, 4] nsswitch/winbindd_dual.c:fork_domain_child(913)
  child daemon request 20
[2006/11/23 18:01:03, 3] nsswitch/winbindd_async.c:winbindd_dual_lookupsid(613)
  [ 4640]: lookupsid S-1-5-32-545
[2006/11/23 18:01:03, 3] nsswitch/winbindd_dual.c:child_read_request(49)
  Got invalid request length: 0

log.wb-WS02:
[2006/11/23 18:01:03, 4] nsswitch/winbindd_dual.c:fork_domain_child(913)
  child daemon request 54
[2006/11/23 18:01:03, 3] nsswitch/winbindd_async.c:winbindd_dual_getsidaliases(950)
  [ 4640]: getsidaliases
[2006/11/23 18:01:03, 3] nsswitch/winbindd_dual.c:child_read_request(49)
  Got invalid request length: 0

log.winbindd-idmap:
[2006/11/23 18:01:03, 4] nsswitch/winbindd_dual.c:fork_domain_child(913)
  child daemon request 45
[2006/11/23 18:01:03, 3] nsswitch/winbindd_async.c:winbindd_dual_sid2gid(388)
  [ 4640]: sid to gid S-1-5-32-545
[2006/11/23 18:01:03, 3] passdb/lookup_sid.c:store_gid_sid_cache(1071)
  store_gid_sid_cache: gid 15123 in cache -> S-1-5-32-545
[2006/11/23 18:01:03, 3] nsswitch/winbindd_dual.c:child_read_request(49)
  Got invalid request length: 0

nmbd and smbd run fine and stable.
Comment 3 Guido Leenders 2006-11-24 16:38:10 UTC
Additional info from log.winbindd:
[2006/11/23 19:58:02, 1] nsswitch/winbindd_group.c:winbindd_getgrnam(370)
  group 0 in domain INVANTIVE does not exist
[2006/11/23 20:58:10, 1] nsswitch/winbindd_group.c:winbindd_getgrnam(370)
  group 0 in domain INVANTIVE does not exist
[2006/11/23 21:58:03, 1] nsswitch/winbindd_group.c:winbindd_getgrnam(370)
  group 0 in domain INVANTIVE does not exist
[2006/11/23 22:58:02, 1] nsswitch/winbindd_group.c:winbindd_getgrnam(370)
  group 0 in domain INVANTIVE does not exist
[2006/11/23 23:58:02, 1] nsswitch/winbindd_group.c:winbindd_getgrnam(370)
  group 0 in domain INVANTIVE does not exist
[2006/11/24 05:43:21, 0] nsswitch/winbindd.c:process_loop(818)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:43:21, 0] nsswitch/winbindd.c:process_loop(837)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:43:56, 0] nsswitch/winbindd.c:process_loop(818)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:43:56, 0] nsswitch/winbindd.c:process_loop(837)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:44:31, 0] nsswitch/winbindd.c:process_loop(818)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:44:31, 0] nsswitch/winbindd.c:process_loop(837)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:45:00, 0] nsswitch/winbindd.c:process_loop(818)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:45:00, 0] nsswitch/winbindd.c:process_loop(837)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:45:06, 0] nsswitch/winbindd.c:process_loop(818)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:45:06, 0] nsswitch/winbindd.c:process_loop(837)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:45:35, 0] nsswitch/winbindd.c:process_loop(818)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:45:35, 0] nsswitch/winbindd.c:process_loop(837)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:45:41, 0] nsswitch/winbindd.c:process_loop(818)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 05:45:41, 0] nsswitch/winbindd.c:process_loop(837)
... keeps repeat till ...
[2006/11/24 10:00:00, 0] nsswitch/winbindd.c:process_loop(837)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 10:04:00, 0] nsswitch/winbindd.c:process_loop(818)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 10:04:00, 0] nsswitch/winbindd.c:process_loop(837)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 10:04:35, 0] nsswitch/winbindd.c:process_loop(818)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 10:04:35, 0] nsswitch/winbindd.c:process_loop(837)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 10:05:10, 0] nsswitch/winbindd.c:process_loop(818)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 10:05:10, 0] nsswitch/winbindd.c:process_loop(837)
  winbindd: Exceeding 200 client connections, no idle connection found
[2006/11/24 10:05:10, 0] nsswitch/winbindd_dual.c:fork_domain_child(765)
  Could not open child pipe: Too many open files
[2006/11/24 10:05:40, 0] lib/fault.c:fault_report(41)
  ===============================================================
[2006/11/24 10:05:40, 0] lib/fault.c:fault_report(42)
  INTERNAL ERROR: Signal 6 in pid 9893 (3.0.23d-0.1.38-1074:1075-SUSE-SLES9)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2006/11/24 10:05:40, 0] lib/fault.c:fault_report(44)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2006/11/24 10:05:40, 0] lib/fault.c:fault_report(45)
  ===============================================================
[2006/11/24 10:05:40, 0] lib/util.c:smb_panic(1599)
  PANIC (pid 9893): internal error
[2006/11/24 10:05:40, 0] lib/util.c:log_stack_trace(1706)
  BACKTRACE: 16 stack frames:
   #0 /usr/sbin/winbindd(log_stack_trace+0x22) [0x80f2b5b]
   #1 /usr/sbin/winbindd(smb_panic+0x6f) [0x80f29fa]
   #2 /usr/sbin/winbindd [0x80e0e5f]
   #3 /usr/sbin/winbindd [0x80e0e70]
   #4 [0xffffe420]
   #5 /lib/tls/libc.so.6(abort+0x129) [0x40272cd9]
   #6 /usr/sbin/winbindd [0x80f80c4]
   #7 /usr/sbin/winbindd(talloc_get_name+0x11) [0x80f85e7]
   #8 /usr/sbin/winbindd(talloc_check_name+0x23) [0x80f8627]
   #9 /usr/sbin/winbindd(talloc_check_name_abort+0x1e) [0x80f4bf1]
   #10 /usr/sbin/winbindd [0x809e2c4]
   #11 /usr/sbin/winbindd [0x807a33e]
   #12 /usr/sbin/winbindd [0x807ae69]
   #13 /usr/sbin/winbindd(main+0x6ae) [0x807b83b]
   #14 /lib/tls/libc.so.6(__libc_start_main+0xe0) [0x4025f250]
   #15 /usr/sbin/winbindd [0x8079bb1]
[2006/11/24 10:05:40, 0] lib/fault.c:dump_core(173)
  dumping core in /var/log/samba/cores/winbindd
Comment 4 Guido Leenders 2006-12-18 04:27:43 UTC
Retested on 3.0.23d.
Same problem:
[2006/12/18 11:17:02, 1] nsswitch/winbindd.c:main(958)
  winbindd version 3.0.23d-0.1.38-1074:1075-SUSE-SLES9 started.
  Copyright The Samba Team 2000-2004
[2006/12/18 11:17:16, 0] lib/fault.c:fault_report(41)
  ===============================================================
[2006/12/18 11:17:16, 0] lib/fault.c:fault_report(42)
  INTERNAL ERROR: Signal 11 in pid 9589 (3.0.23d-0.1.38-1074:1075-SUSE-SLES9)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2006/12/18 11:17:16, 0] lib/fault.c:fault_report(44)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2006/12/18 11:17:16, 0] lib/fault.c:fault_report(45)
  ===============================================================
[2006/12/18 11:17:16, 0] lib/util.c:smb_panic(1599)
  PANIC (pid 9589): internal error
[2006/12/18 11:17:16, 0] lib/util.c:log_stack_trace(1706)
  BACKTRACE: 27 stack frames:
   #0 /usr/sbin/winbindd(log_stack_trace+0x22) [0x80f2b5b]
   #1 /usr/sbin/winbindd(smb_panic+0x6f) [0x80f29fa]
   #2 /usr/sbin/winbindd [0x80e0e5f]
   #3 /usr/sbin/winbindd [0x80e0e70]
   #4 [0xffffe420]
   #5 /usr/lib/libkrb5.so.17 [0x400b8d12]
   #6 /usr/sbin/winbindd(kerberos_kinit_password_ext+0x121) [0x81cec3b]
   #7 /usr/sbin/winbindd(kerberos_kinit_password+0x4e) [0x81cf7ec]
   #8 /usr/sbin/winbindd(cli_session_setup_spnego+0x368) [0x810fcc8]
   #9 /usr/sbin/winbindd [0x8093513]
   #10 /usr/sbin/winbindd [0x8094ecf]
   #11 /usr/sbin/winbindd(init_dc_connection+0x70) [0x80952b1]
   #12 /usr/sbin/winbindd(cm_connect_lsa+0x24) [0x8095fa8]
   #13 /usr/sbin/winbindd(msrpc_sid_to_name+0x96) [0x8097a56]
   #14 /usr/sbin/winbindd [0x80871df]
   #15 /usr/sbin/winbindd [0x809ceed]
   #16 /usr/sbin/winbindd(fill_passdb_alias_grmem+0x79) [0x809d331]
   #17 /usr/sbin/winbindd [0x807d9b3]
   #18 /usr/sbin/winbindd(winbindd_getgrent+0x714) [0x8080166]
   #19 /usr/sbin/winbindd [0x807a0a4]
   #20 /usr/sbin/winbindd [0x807a9d9]
   #21 /usr/sbin/winbindd [0x807a871]
   #22 /usr/sbin/winbindd [0x807a33e]
   #23 /usr/sbin/winbindd [0x807ae69]
   #24 /usr/sbin/winbindd(main+0x6ae) [0x807b83b]
   #25 /lib/tls/libc.so.6(__libc_start_main+0xe0) [0x4025f250]
   #26 /usr/sbin/winbindd [0x8079bb1]
[2006/12/18 11:17:16, 0] lib/fault.c:dump_core(173)
  dumping core in /var/log/samba/cores/winbindd
Comment 5 Guido Leenders 2006-12-18 04:29:29 UTC
Created attachment 2240 [details]
Core dump of winbindd
Comment 6 Denis Häußer 2006-12-28 03:24:53 UTC
*** Bug 4304 has been marked as a duplicate of this bug. ***
Comment 7 Guenther Deschner 2007-02-20 08:10:16 UTC
Can you all please recheck with recent 3.0.24 packages and see if that error persists?
Comment 8 Guido Leenders 2007-02-24 06:52:28 UTC
Installed 3.0.24.
Join AD according to http://www.zdnetasia.com/insight/network/0,39044847,39081966-2,00.htm
Still panic:

In log.wb-INVANTIVE:

[2007/02/24 13:49:57, 0] lib/fault.c:fault_report(41)
  ===============================================================
[2007/02/24 13:49:57, 0] lib/fault.c:fault_report(42)
  INTERNAL ERROR: Signal 11 in pid 14092 (3.0.24-5.1.52-1205-SUSE-SLES9)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2007/02/24 13:49:57, 0] lib/fault.c:fault_report(44)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2007/02/24 13:49:57, 0] lib/fault.c:fault_report(45)
  ===============================================================
[2007/02/24 13:49:57, 0] lib/util.c:smb_panic(1599)
  PANIC (pid 14092): internal error
[2007/02/24 13:49:57, 0] lib/util.c:log_stack_trace(1706)
  BACKTRACE: 29 stack frames:
   #0 /usr/sbin/winbindd(log_stack_trace+0x22) [0x80f3c4b]
   #1 /usr/sbin/winbindd(smb_panic+0x6f) [0x80f3aea]
   #2 /usr/sbin/winbindd [0x80e1f4f]
   #3 /usr/sbin/winbindd [0x80e1f60]
   #4 [0xffffe420]
   #5 /usr/lib/libkrb5.so.17 [0x400b7d12]
   #6 /usr/sbin/winbindd(kerberos_kinit_password_ext+0x121) [0x81d08eb]
   #7 /usr/sbin/winbindd(ads_kinit_password+0x109) [0x81d0c73]
   #8 /usr/sbin/winbindd [0x81c7d20]
   #9 /usr/sbin/winbindd(ads_sasl_bind+0x129) [0x81c84c2]
   #10 /usr/sbin/winbindd(ads_connect+0x2aa) [0x81c1810]
   #11 /usr/sbin/winbindd [0x809ae83]
   #12 /usr/sbin/winbindd [0x809d751]
   #13 /usr/sbin/winbindd [0x8084e24]
   #14 /usr/sbin/winbindd [0x80852c8]
   #15 /usr/sbin/winbindd [0x808852f]
   #16 /usr/sbin/winbindd(winbindd_dual_list_trusted_domains+0xa6) [0x80919cb]
   #17 /usr/sbin/winbindd [0x809f831]
   #18 /usr/sbin/winbindd [0x80a0dec]
   #19 /usr/sbin/winbindd [0x809f497]
   #20 /usr/sbin/winbindd(async_request+0x15a) [0x809f0bc]
   #21 /usr/sbin/winbindd(init_child_connection+0x233) [0x8081f28]
   #22 /usr/sbin/winbindd(async_domain_request+0xfb) [0x809f5f2]
   #23 /usr/sbin/winbindd [0x8081a33]
   #24 /usr/sbin/winbindd(rescan_trusted_domains+0x37) [0x8081ce9]
   #25 /usr/sbin/winbindd [0x807ae4c]
   #26 /usr/sbin/winbindd(main+0x6ae) [0x807ba4b]
   #27 /lib/tls/libc.so.6(__libc_start_main+0xe0) [0x4025e250]
   #28 /usr/sbin/winbindd [0x8079d71]
[2007/02/24 13:49:57, 0] lib/fault.c:dump_core(173)
  dumping core in /var/log/samba/cores/winbindd

In samba.log:
[2007/02/24 13:49:57, 1] nsswitch/winbindd_util.c:trustdom_recv(234)
  Could not receive trustdoms

I will upload the core dump.

Please note that the error changed, maybe I did something wrong when joining AD and winbind was not so friendly in it's reaction. I don't see name_deadbeef anymore.

smbclient //<IP adres of AD server/c$ -k 

works fine, without asking password.
Comment 9 Guido Leenders 2007-02-24 07:28:51 UTC
Created attachment 2308 [details]
Core dump
Comment 10 Guenther Deschner 2011-05-11 11:42:51 UTC
long resolved, closing