Bug 4149 - Debian: smbd not starting up (via swat and CLI's /etc/init.d/samba start)
Debian: smbd not starting up (via swat and CLI's /etc/init.d/samba start)
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.23c
x86 Linux
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-03 21:30 UTC by Mag
Modified: 2011-03-06 09:27 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mag 2006-10-03 21:30:15 UTC
# uname -a
Linux debian 2.6.15-1-686 #2 Mon Mar 6 15:27:08 UTC 2006 i686 GNU/Linux

#cat /etc/issue.net
Debian GNU/Linux testing/unstable

Log errors:

[2006/10/03 22:29:41, 0] smbd/server.c:main(847)
  smbd version 3.0.23c started.
  Copyright Andrew Tridgell and the Samba Team 1992-2006
[2006/10/03 22:29:41, 0] passdb/pdb_interface.c:make_pdb_method_name(174)
  No builtin nor plugin backend for tdbsam, found
[2006/10/03 22:29:41, 0] lib/util.c:smb_panic(1592)
  PANIC (pid 6009): pdb_get_methods_reload: failed to get pdb methods for backend tdbsam,

[2006/10/03 22:29:41, 0] lib/util.c:log_stack_trace(1699)
  BACKTRACE: 7 stack frames:
   #0 /usr/sbin/smbd(log_stack_trace+0x23) [0x822b763]
   #1 /usr/sbin/smbd(smb_panic+0x46) [0x822b856]
   #2 /usr/sbin/smbd [0x81ea941]
   #3 /usr/sbin/smbd(initialize_password_db+0xe) [0x81ea98e]
   #4 /usr/sbin/smbd(main+0x591) [0x82c1cd1]
   #5 /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xc8) [0xb7c37ea8]
   #6 /usr/sbin/smbd [0x8082a31]
[2006/10/03 22:29:41, 0] lib/util.c:smb_panic(1600)
  smb_panic(): calling panic action [/usr/share/samba/panic-action 6009]
[2006/10/03 22:29:41, 0] lib/util.c:smb_panic(1608)
  smb_panic(): action returned status 0
[2006/10/03 22:29:41, 0] lib/fault.c:dump_core(173)
  dumping core in /var/log/samba/cores/smbd
Comment 1 Spammer 2007-04-28 04:18:26 UTC
Created attachment 2499
Comment 2 Volker Lendecke 2011-03-06 09:27:00 UTC
Closing as WORKSFORME. This looks like a packaging issue. Please re-open if it happens with later releases and upload your smb.conf and a debug level 10 log of smbd when this happens.