Bug 4142 - testparm: segmentation fault
testparm: segmentation fault
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.23c
x86 FreeBSD
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-03 02:51 UTC by Oleg Lomaka
Modified: 2014-10-01 07:26 UTC (History)
1 user (show)

See Also:


Attachments
smb.conf file (401 bytes, text/plain)
2006-10-03 23:04 UTC, Oleg Lomaka
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Lomaka 2006-10-03 02:51:11 UTC
% testparm -s -v --parameter-name "msdf proxy"
Load smb config files from /usr/local/etc/smb.conf
Loaded services file OK.
zsh: segmentation fault   -s -v --parameter-name "msdf proxy"


(gdb) where
#0  0x08062e56 in lp_add_home (pszHomename=0xffffffff <Address 0xffffffff out of bounds>,
    iDefaultService=135151696, user=0x282e92d8 "", pszHomedir=0x1 <Address 0x1 out of bounds>)
    at param/loadparm.c:2568
#1  0x0805b0d7 in init_printer_values (pService=0x6) at param/loadparm.c:1291
#2  0x0805a015 in _start ()
#3  0x00000006 in ?? ()
(gdb) frame 0
#0  0x08062e56 in lp_add_home (pszHomename=0xffffffff <Address 0xffffffff out of bounds>,
    iDefaultService=135151696, user=0x282e92d8 "", pszHomedir=0x1 <Address 0x1 out of bounds>)
    at param/loadparm.c:2568
2568            if (!(*(ServicePtrs[iDefaultService]->szPath))
(gdb) list
2563            i = add_a_service(ServicePtrs[iDefaultService], pszHomename);
2564
2565            if (i < 0)
2566                    return (False);
2567
2568            if (!(*(ServicePtrs[iDefaultService]->szPath))
2569                || strequal(ServicePtrs[iDefaultService]->szPath, lp_pathname(GLOBAL_SECTION_SNUM))) {
2570                    pstrcpy(newHomedir, pszHomedir);
2571                    string_set(&ServicePtrs[i]->szPath, newHomedir);
2572            }


I still have a core dump, so can provide further info by request. 

Thanks.
Comment 1 Jeremy Allison 2006-10-03 17:54:06 UTC
Can you attach your smb.conf please ?
Jeremy.
Comment 2 Oleg Lomaka 2006-10-03 23:04:32 UTC
Created attachment 2171 [details]
smb.conf file
Comment 3 Volker Lendecke 2009-01-25 13:51:27 UTC
Oleg, can you try with latest git code?

Thanks

Volker
Comment 4 Karolin Seeger 2014-10-01 07:26:02 UTC
(In reply to comment #3)
> Oleg, can you try with latest git code?
> 
> Thanks
> 
> Volker

Cannot reproduce with Samba 4.1.13.
Closing out bug report.

Please feel free to re-open if it's still an issue.

Thanks!