Bug 4127 - --without-libiconv is broken (probably since the change to --without-iconv)
--without-libiconv is broken (probably since the change to --without-iconv)
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.23c
x86 OpenBSD
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 15:35 UTC by Brad Davis
Modified: 2009-12-11 09:03 UTC (History)
0 users

See Also:


Attachments
Patch for configure.in and configure (2.99 KB, patch)
2006-09-26 15:40 UTC, Brad Davis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Davis 2006-09-26 15:35:53 UTC
Using --without-libiconv gives the message about --with-libiconv must have a directory argument.  The attached patch (for configure, not configure.in) fixes this and requires --with-libiconv to have an argument (possibly not what was intended).

diff -rc samba-3.0.23c/source/configure hold/source/configure
*** samba-3.0.23c/source/configure      Thu Aug 31 12:57:32 2006
--- hold/source/configure       Tue Sep 26 14:15:27 2006
***************
*** 29818,29841 ****
  if test "${with_libiconv+set}" = set; then
    withval="$with_libiconv"
  
!   if test "$withval" = "no" ; then
      { { echo "$as_me:$LINENO: error: argument to --with-libiconv must be a dir
ectory" >&5
  echo "$as_me: error: argument to --with-libiconv must be a directory" >&2;}
     { (exit 1); exit 1; }; }
    else
!      if test "$withval" != "yes" ; then
        ICONV_PATH_SPEC=yes
          LOOK_DIRS="$withval"
       fi
    fi
  
  fi;
  
  for i in $LOOK_DIRS ; do
      save_LIBS=$LIBS
      save_LDFLAGS=$LDFLAGS
      save_CPPFLAGS=$CPPFLAGS
-     ICONV_FOUND="no"
      unset libext
      CPPFLAGS="$CPPFLAGS -I$i/include"
  
--- 29818,29844 ----
  if test "${with_libiconv+set}" = set; then
    withval="$with_libiconv"
  
!   if test "$withval" = "yes" ; then
      { { echo "$as_me:$LINENO: error: argument to --with-libiconv must be a dir
ectory" >&5
  echo "$as_me: error: argument to --with-libiconv must be a directory" >&2;}
     { (exit 1); exit 1; }; }
    else
!      if test "$withval" != "no" ; then
        ICONV_PATH_SPEC=yes
          LOOK_DIRS="$withval"
+      else
+         LOOK_DIRS=""
       fi
    fi
  
  fi;
  
+ ICONV_FOUND="no"
  for i in $LOOK_DIRS ; do
      save_LIBS=$LIBS
      save_LDFLAGS=$LDFLAGS
      save_CPPFLAGS=$CPPFLAGS
      unset libext
      CPPFLAGS="$CPPFLAGS -I$i/include"
Comment 1 Brad Davis 2006-09-26 15:40:44 UTC
Created attachment 2161 [details]
Patch for configure.in and configure
Comment 2 Karolin Seeger 2009-12-11 09:03:13 UTC
Parts of the patch seem to be upstream. Cannot reproduce the issue.
Closing out bug report.
Please reopen if it's still an issue in current Samba versions.

Thanks!