Bug 4124 - Pb copying files OS2 EAs to Samba server
Pb copying files OS2 EAs to Samba server
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.23c
x86 OS/2
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-25 04:50 UTC by Alain GORLIER
Modified: 2009-09-17 15:38 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alain GORLIER 2006-09-25 04:50:06 UTC
We have a problem copying OS2 files with EA's to samba server from an OS2 client.
Looks like there is another bug similar, but our bug seems to be more simple.

Not using ea support in smb.conf OS2 client says :
"The extended attributes for the file or directory were discarded because the target file system does not support them. 1 file(s) copied".
(the file is normally copied with attributes.)

Overwriting the same file : same message.

Using the ea support in smb.conf OS2 client says :
"The extended attributes for the file or directory were discarded because the target file system does not support them. 1 file(s) copied".
(the file is normally copied with attributes.)

BUT, overwriting the same file : no error message !
(the file is normally copied with attributes.)

So, the problem is : copy files with EA's when target file does not exist.
Comment 1 Alain GORLIER 2006-09-27 10:00:54 UTC
I made a mistake. The OS2 EA's are never copied to Samba server.
So, please read this post instead :

We have a problem copying OS2 files with EA's to samba server from an OS2 client.
Looks like there is another bug similar, but our bug seems to be more simple.

Not using ea support in smb.conf OS2 client says :
"The extended attributes for the file or directory were discarded because the
target file system does not support them. 1 file(s) copied".
( no extended attributes are copied )

Overwriting the same file : same message.
 
Using the ea support in smb.conf OS2 client says :
"The extended attributes for the file or directory were discarded because the
target file system does not support them. 1 file(s) copied".
( no extended attributes are copied )

BUT, overwriting the same file : no more error message !
(no extended attributes are copied )
 
So, the problem is : OS2 EA's are not copied. Different messages if file exists or not.
Comment 2 Alain GORLIER 2006-10-09 06:14:18 UTC
up !
Comment 3 Björn Jacke 2009-09-17 15:38:01 UTC
can you retry with 3.4.1? Chances are good it works now. If problem still exists, please reopen this bug!