Bug 4117 - lib/util.c long long problem
lib/util.c long long problem
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.23c
x86 Other
: P3 regression
: none
Assigned To: Tim Potter
Samba QA Contact
:
: 4118 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 16:35 UTC by Larry Manulak
Modified: 2011-03-06 08:09 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Manulak 2006-09-21 16:35:04 UTC
Error: "lib/util.c", line 1591: error: invalid type combination.

OS: SCO OpenServer 5.0.7 and SCO's native compiler but probably will get this on all compilers that do not support long long.

configure properly discovers that SCO's cc does not support long long but the offending part of util.c does not have a guarding #if for this. Must be an over sight as other similar statements do.

BTW, why are there any "long long" types anywhere, since somebody went to the trouble of defining int64 as long long if it is available or as long if that is all that is available? It seems a shame not to use it.

Thanks.


Larry Manulak
Programmer
Omega Computer Services Ltd.
Comment 1 Larry Manulak 2006-09-21 16:42:04 UTC
*** Bug 4118 has been marked as a duplicate of this bug. ***
Comment 2 Volker Lendecke 2011-03-06 08:09:31 UTC
We've got the convention with int64 etc for a while now. Please re-open if this is still an issue with Samba 3.5.