Bug 411 - Cannot view filenames with 8bit characters
Cannot view filenames with 8bit characters
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0preX
All Windows XP
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-05 08:39 UTC by Marc Groot Koerkamp
Modified: 2005-11-14 09:29 UTC (History)
1 user (show)

See Also:


Attachments
debug level 10 log file (4.79 KB, text/plain)
2003-09-05 08:40 UTC, Marc Groot Koerkamp
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Groot Koerkamp 2003-09-05 08:39:04 UTC
Previous CVS versions of samba 3 couldn't show filenames with 8 bit 
characters. Instead a filename with all squares was displayed.

Latest CVS shows me the characters before the special 8bit character and 
continious from that position with squares.

A debug level = 10 log fragment is attached.
Comment 1 Marc Groot Koerkamp 2003-09-05 08:40:26 UTC
Created attachment 124 [details]
debug level 10 log file
Comment 2 TAKAHASHI Motonobu 2003-09-07 08:18:40 UTC
Have you already installed iconv() and 
set "dos charset" and "unix charset" parameters correctly?

To handle NON-ASCII characters correctly, these are needed.
Comment 3 Marc Groot Koerkamp 2003-09-08 05:15:13 UTC
I just compiled iconv 1.9.1 from source and used --with-iconvlib=/usr/local 
with latest CVS with as result nobody could login.

I switched back to the RC2 source with better results.
It appears that the default unix charset was utf8 instead of cp850 like the 
manual said. (testparm -v)

Setting it to cp850 worked a little bit better. I can see the special chars 
again but now smb crashed because of a missing UTF-8.so 
in /usr/local/samba/lib/charset

How can i compile samba so that UTF-8.so is created?
Comment 4 Marc Groot Koerkamp 2003-09-08 08:00:04 UTC
After downloading the latest gcc (version 3.3.1-3) from RH rawhide and 
recompiling libiconv and samba 3 RC2 the problem is solved.
Comment 5 Gerald (Jerry) Carter 2003-09-10 06:59:35 UTC
Thanks for letting us know.
Comment 6 Gerald (Jerry) Carter 2005-02-07 09:06:13 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 7 Gerald (Jerry) Carter 2005-08-24 10:25:44 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 8 Gerald (Jerry) Carter 2005-11-14 09:29:24 UTC
database cleanup