Bug 4107 - Directory creation : Bad return code for OS/2 clients
Directory creation : Bad return code for OS/2 clients
Status: RESOLVED DUPLICATE of bug 4122
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.23c
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 05:11 UTC by nicolas
Modified: 2006-09-25 04:12 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nicolas 2006-09-18 05:11:14 UTC
When creating a directory from an os/2 client to a samba fileserver. It fails whith an unknown error code return from samba server to os/2 client when directory already exists.
Return code is OK when directory doesn't exist.

See sample below :
md \\shdesdev\complusdev\DUMP
SYS0317: The system cannot find message  0183 in message file OSO001.MSG.
Comment 1 Guenter Kukkukk 2006-09-22 15:19:09 UTC
Hi Nicolas,

I tried to reproduce the bug by using the same procedure
you described on the samba mailing list.

In _both_ cases - against a warpserver and against samba3
(latest svn build #18826) - I get 
SYS1248: A subdirectory or file \\linux300\samba3tst\test already exists.
which is the expected behaviour.
Both sniffs show a DosErr 0x05 (access denied), which is fine.

Your used samba version (Version 3.0.23c-SerNet-RedHat) is
slightly older than the one I used.

Can you please sniff both cases and send them here as an attachment.
Which version of OS/2 are you using?

Cheers, Guenter Kukkukk

btw 
SYS0317: The system cannot find message  0183 in message file OSO001.MSG.
is just saying that msg SYS0317 isn't included in the main msg file.
Typing 'helpmsg SYS0317' is showing the same.
Not all SYSXXXX messages have a corresponding entry in the main msg file.
Comment 2 nicolas 2006-09-25 04:12:14 UTC
Hello, This BUG is the same as the BUG #4122. As it as more details in it. I suppose we can close this one.

*** This bug has been marked as a duplicate of 4122 ***