Bug 4106 - "net rpc share -l" gets mangled output when there is a quote in the Description field
"net rpc share -l" gets mangled output when there is a quote in the Descripti...
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: net utility
3.0.23c
All Linux
: P3 normal
: none
Assigned To: Jim McDonough
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 19:34 UTC by Thomas Chan
Modified: 2008-06-23 16:18 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Chan 2006-09-15 19:34:42 UTC
When there is a quote in the comments field, the next entry gets run into the description field.

Two printers (as shown in windows):
XXXXprinter    IT "XXXX" printer
YYYYprinter    IT desktop printer
ZZZZprinter    IT server printer

When running "net rpc share -l -S printserver", here's the relevant output:

Share name   Type     Description
----------   ----     -----------
XXXXprinter  Print    IT YYYYprinter    Print    IT desktop printer
ZZZZprinter  Print    IT server printer
Comment 1 Kai Blin 2008-06-23 16:18:22 UTC
I can't reproduce that one with 3.0.30. I assume it's fixed. Please reopen the bug if this still fails for you.