Bug 4073 - smbpasswd isn't case sensitive when distinguishing users
smbpasswd isn't case sensitive when distinguishing users
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.23a
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 10:11 UTC by Mark Slade
Modified: 2006-08-31 10:32 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Slade 2006-08-31 10:11:53 UTC
If smbpasswd already has an entry for UsEr, then smbpasswd -a uSeR with a new password will overwrite the UsEr entry rather than creating a new one for uSeR.

Demonstrated:
[root@err samba]# cat smbpasswd
mark:500:7AF3DE1E1D6C5927B8FCC6137C839435:F5B57AF6A5E35726D5087508AD5D5969:[U          ]:LCT-44F6FA94:
[root@err samba]# smbpasswd -a Mark
New SMB password:
Retype new SMB password:
[root@err samba]# cat smbpasswd
mark:500:B267DF22CB945E3EAAD3B435B51404EE:36AA83BDCAB3C9FDAF321CA42A31C3FC:[U          ]:LCT-44F6FBD7:
[root@err samba]# cat /dev/null > ./smbpasswd
[root@err samba]# smbpasswd -a Mark
New SMB password:
Retype new SMB password:
Added user Mark.
[root@err samba]# cat smbpasswd
Mark:501:B267DF22CB945E3EAAD3B435B51404EE:36AA83BDCAB3C9FDAF321CA42A31C3FC:[U          ]:LCT-44F6FBFA:
[root@err samba]# smbpasswd -a mark
New SMB password:
Retype new SMB password:
[root@err samba]# cat smbpasswd
Mark:501:6B9C36DEAC41F541AAD3B435B51404EE:973AFC7D700ADB85BECD0ABB59F690B7:[U          ]:LCT-44F6FC6C:
Comment 1 Gerald (Jerry) Carter 2006-08-31 10:32:53 UTC
Mark,  This is by design since Windows usernames are case insensitive.