Bug 4061 - Cannot join to domain using samba & LDAP
Cannot join to domain using samba & LDAP
Status: RESOLVED DUPLICATE of bug 4062
Product: Samba 3.0
Classification: Unclassified
Component: smbldap-tools
3.0.23a
x86 All
: P3 critical
: none
Assigned To: Tournier Jerome
smbldap-tools team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-27 23:49 UTC by Muhammad Rizwan Ali
Modified: 2006-08-29 08:38 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Muhammad Rizwan Ali 2006-08-27 23:49:40 UTC
I have bought SuSE Enterprise Server 10 from Novell. I have configured LDAP & Samba as PDC for my local LAN. Now when I try to join my clients workstations using the Administrator as username, I get the error " user not found". Infact, when I see the LDAP database, the machine account is added. But still the clients do net get added to the Domain. Kindly help me in this regard.

The following is a configuration of my GLOBAL Seetings in smb.conf file:

[global]
        workgroup = SCS
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = Z:
        acl compatibility = win2k
      add machine script = /sbin/yast /usr/share/YaST2/data/add_machine.ycp %m$
        domain logons = Yes
        domain master = Yes
        idmap backend = ldap:ldap://localhost
        idmap gid = 10000-20000
        idmap uid = 10000-20000
        ldap admin dn = cn=Administrator,dc=scs,dc=com
        ldap group suffix = ou=group
        ldap idmap suffix = ou=Idmap
        ldap machine suffix = ou=Computers
        ldap passwd sync = Yes
        ldap ssl = Off
        ldap suffix = dc=scs,dc=com
        ldap user suffix = ou=people
        local master = Yes
        logon script = logon.bat
        netbios name = SCSPDC
        os level = 65
        passdb backend = ldapsam:ldap://127.0.0.1
        preferred master = Yes
        restrict anonymous = no
        security = user
        server signing = Auto
        server string = SCS PDC
        username map = /etc/samba/smbusers
        wins support = Yes
Comment 1 Björn Jacke 2006-08-29 08:38:15 UTC

*** This bug has been marked as a duplicate of 4062 ***