Bug 4054 - deleting machine in ldap via srvmgr not possible
deleting machine in ldap via srvmgr not possible
Status: RESOLVED DUPLICATE of bug 4055
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.23b
Other Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-26 11:23 UTC by Björn Jacke
Modified: 2006-08-29 08:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2006-08-26 11:23:46 UTC
deleting a machine via NT4 srvmgr is not possible with ldap as backend, probably some becomeroot missing ...:

[2006/08/26 17:08:43.077782, 3] passdb/pdb_ldap.c:ldapsam_delete_sam_account(1687)
  ldapsam_delete_sam_account: Deleting user NT4MIG$ from LDAP.
[2006/08/26 17:08:43.077822, 5] lib/smbldap.c:smbldap_search_ext(1179)
  smbldap_search_ext: base => [dc=mydom,dc=de], filter => [(&(uid=NT4MIG$)(objectclass=sambaSamAccount))], scope => [2]
[2006/08/26 17:08:43.077858, 0] lib/smbldap.c:smbldap_open(1009)
  smbldap_open: cannot access LDAP when not root..
Comment 1 Volker Lendecke 2006-08-26 11:38:51 UTC
Are you really using 3.0.21b? If yes, can you please retry with 3.0.23b?

Thanks,

Volker
Comment 2 Björn Jacke 2006-08-26 11:43:49 UTC
sorry, I use 23b ...
Comment 3 Björn Jacke 2006-08-29 08:50:36 UTC

*** This bug has been marked as a duplicate of 4055 ***