Bug 4042 - Samba shares not accessible
Samba shares not accessible
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.23b
x86 FreeBSD
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 01:29 UTC by Daniel (The recipient's e-mail address was not found in the recipient's e-mail system.)
Modified: 2016-04-29 01:37 UTC (History)
1 user (show)

See Also:


Attachments
level 10 of samba log (132.92 KB, application/x-zip-compressed)
2006-09-05 20:39 UTC, Daniel (The recipient's e-mail address was not found in the recipient's e-mail system.)
no flags Details
level 10 samba log (new) (265.21 KB, application/x-zip-compressed)
2006-09-06 20:02 UTC, Daniel (The recipient's e-mail address was not found in the recipient's e-mail system.)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel (The recipient's e-mail address was not found in the recipient's e-mail system.) 2006-08-22 01:29:15 UTC
I have upgraded Samba port version 3.0.23 -> 3.0.23b on FreeBSD 6.1 server (member server of Win2003 AD environment) and found that I cannot access the shares anymore. I revert back 3.0.23 and it works fine.

net ads join, wbinfo -t, wbinfo -u, wbinfo -g, ntlm_auth all work fine but when I fail to browse the samba shares from WinXP, I started troubleshooting with using smbclient and I've the following error message:

check_ntlm_password:  Authentication for user [userid] -> [userid] FAILED with error NT_STATUS_NO_LOGON_SERVERS
[2006/08/21 21:02:44, 5] auth/auth_util.c:free_user_info(1816)
  attempting to free (and zero) a user_info structure
[2006/08/21 21:02:44, 10] auth/auth_util.c:free_user_info(1820)
  structure was created for teststaff
[2006/08/21 21:02:44, 3] smbd/error.c:error_packet(146)
  error packet at smbd/sesssetup.c(99) cmd=115 (SMBsesssetupX) NT_STATUS_NO_LOGON_SERVERS

Any idea why the auth is broken because the release notes of 3.0.23a and 3.0.23b tells me it should be an improvement. I've failed on 3.0.23a as well.
Comment 1 Gerald (Jerry) Carter 2006-08-22 11:13:30 UTC
Not enough information here to comment.  Please attach your smb.conf 
and a gzipped level 10 debug log from smbd.
Comment 2 Daniel (The recipient's e-mail address was not found in the recipient's e-mail system.) 2006-09-01 23:51:46 UTC
Problem disappears after upgrading to version 3.0.23c
Comment 3 Gerald (Jerry) Carter 2006-09-03 07:40:56 UTC
Thanks for the feedback.
Comment 4 Daniel (The recipient's e-mail address was not found in the recipient's e-mail system.) 2006-09-05 20:39:26 UTC
Created attachment 2126 [details]
level 10 of samba log
Comment 5 Daniel (The recipient's e-mail address was not found in the recipient's e-mail system.) 2006-09-05 20:45:41 UTC
Hi, I am sorry that I need to reopen this request because the problem still exists as it happens intermittently.

I was misled to think the problem is resolved by upgrading to 3.0.23c but not really the case. It worked when samba started up for the first time but when samba is restarted, the problem randomly comes back and the connection to shares are broken.

I have attached level 10 log for debugging. Thanks.
Comment 6 Volker Lendecke 2006-09-06 03:35:39 UTC
The NO_LOGON_SERVERS happens at 22:49:16, the winbind logs end at 22:49:11. Log files from the actual winbind failure are missing, sorry.

Volker
Comment 7 Daniel (The recipient's e-mail address was not found in the recipient's e-mail system.) 2006-09-06 20:02:14 UTC
Created attachment 2128 [details]
level 10 samba log (new)
Comment 8 Daniel (The recipient's e-mail address was not found in the recipient's e-mail system.) 2006-09-06 20:13:03 UTC
New log attached. I've let samba running for longer time this time to build up logs. Somehow, I think I've narrowed down the problem and found that it happened during samba restarts.

Interestingly, I'm getting NO_LOGON_SERVERS with samba restart using FreeBSD startup script but if I'm to stop and then start samba, it seems to work fine. Is it something to do how samba script interact with FreeBSD as it is calling /etc/rc.subr (in attachment) for samba restart, start or stop process.

For information, I've scheduled samba to restart daily after midnight via cron.
Comment 9 Daniel (The recipient's e-mail address was not found in the recipient's e-mail system.) 2006-09-27 08:28:09 UTC
Hi, I think the problem is resolved with FreeBSD port maintainer updated the Makefile for samba3
Comment 10 Scott 2006-09-28 11:27:53 UTC
At this point, I simply wish to add a "me too."  After successful upgrades on several machines, including production servers, one and only one server is giving various errors.  Samba 3.0.23c,1 will work for awhile.  Then, after a few hours, the users will report they can't access their shares.  Backing out to 3.0.22,1 fixes the issue.  This is on FreeBSD-6.1-STABLE.

Trying Daniel's solution of starting samba without using the rc.d scripts didn't fix the problem.  As it was a production machine, I wasn't able to take the time to set up extra debugging.  The only clues that I have are that /var/log/samba/smbd.log says

[2006/09/27 17:42:22, 0] smbd/server.c:open_sockets_smbd(443)
  open_sockets_smbd: accept: Software caused connection abort
[2006/09/28 10:15:37, 0] smbd/server.c:open_sockets_smbd(443)
  open_sockets_smbd: accept: Software caused connection abort
[2006/09/28 10:17:49, 0] smbd/server.c:open_sockets_smbd(443)
  open_sockets_smbd: accept: Software caused connection abort
[2006/09/28 10:20:53, 0] smbd/server.c:open_sockets_smbd(443)
  open_sockets_smbd: accept: Software caused connection abort
[2006/09/28 10:36:17, 0] smbd/server.c:open_sockets_smbd(443)
  open_sockets_smbd: accept: Software caused connection abort

Trying with smbclient -L <servername> -N will, (once it stops working) give the message 

protocol negotiation failed

The log for one of the machines having the problem had the entry

[2006/09/26 08:09:04, 0] lib/util_sock.c:write_data(562)
  write_data: write failure in writing to client 192.0.0.189. Error Broken pipe


I realize this isn't enough information to be useful, especially as it is working without trouble on three other production servers, however, I just wanted to note that Daniel isn't the only one having issues.
Comment 11 Scott 2006-09-28 19:52:00 UTC
(In reply to comment #10)
> At this point, I simply wish to add a "me too."  After successful upgrades on
> several machines, including production servers, one and only one server is
> giving various errors.  Samba 3.0.23c,1 will work for awhile.  Then, after a
> few hours, the users will report they can't access their shares.  Backing out
> to 3.0.22,1 fixes the issue.  This is on FreeBSD-6.1-STABLE.
> 
> 

I should have added that this is a Windows NT4.0 domain with security = server in smb.conf.  Therefore, I don't think the moving of secrets.tdb is the problem.  (I don't know if secrets.tdb was moved only in FreeBSD or not.)
Users log in with their NT domain password. 

Comment 12 Michael Kreykenbohm 2006-11-23 11:36:30 UTC
(In reply to comment #11)
("me too")
Just installed a 6.2-RC1 FreeBSD AMD64 machine (new motherboard so I had to use it) with version 3.0.23c. After several hours, the shares disappear. restarting samba did not resolv the problem, rebooting the machine did.
Also, on restart, the nmbd process did not die (sometimes).


Comment 13 Björn Jacke 2016-04-29 01:37:55 UTC
please file a new bug if this is still a problem with a recent samba version. thank you.