Bug 4036 - rpcclient adddriver fails when lots of driver-files
rpcclient adddriver fails when lots of driver-files
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.10
Other Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-20 04:58 UTC by Brian Ipsen
Modified: 2009-02-25 06:07 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Ipsen 2006-08-20 04:58:43 UTC
Hi.

I try to add the driver for Canon PIXMA iP4000 with the following command:

rpcclient -Uroot%passwd -c 'adddriver "Windows NT x86" \
  "Canon PIXMA iP4000":CNMDR64.DLL: \
  CNMCP64.DLL:CNMUI64.DLL:CNMMH64.HLP:   \
  NULL:RAW:CNB_2200.TBL,CNMD564.DLL,CNMFU64.DLL,CNMIN64.INI,CNMMH640.405, \
  CNMMH640.406,CNMMH640.407,CNMMH640.408,CNMMH640.40b,CNMMH640.40c, \
  CNMMH640.40e,CNMMH640.410,CNMMH640.413,CNMMH640.414,CNMMH640.415, \
  CNMMH640.419,CNMMH640.41d,CNMMH640.816,CNMMH640.c0a,CNMMH64.CNT, \
  CNMMT640.405,CNMMT640.406,CNMMT640.407,CNMMT640.408,CNMMT640.40b, \
  CNMMT640.40c,CNMMT640.40e,CNMMT640.410,CNMMT640.413,CNMMT640.414, \
  CNMMT640.415,CNMMT640.419,CNMMT640.41d,CNMMT640.816,CNMMT640.c0a, \
  CNMOP64.DLL,CNMP064.DAT,CNMP164.DAT,CNMP264.DAT,CNMPH640.405, \
  CNMPH640.406,CNMPH640.407,CNMPH640.408,CNMPH640.40b,CNMPH640.40c, \
  CNMPH640.40e,CNMPH640.410,CNMPH640.413,CNMPH640.414,CNMPH640.415, \
  CNMPH640.419,CNMPH640.41d,CNMPH640.816,CNMPH640.c0a,CNMPH64.CNT, \
  CNMPH64.HLP,CNMPI64.DLL,CNMPT640.405,CNMPT640.406,CNMPT640.407, \
  CNMPT640.408,CNMPT640.40b,CNMPT640.40c,CNMPT640.40e,CNMPT640.410, \
  CNMPT640.413,CNMPT640.414,CNMPT640.415,CNMPT640.419,CNMPT640.41d, \
  CNMPT640.816,CNMPT640.c0a,CNMPV64.EXE,CNMSB64.DLL,CNMSD64.EXE, \
  CNMSH640.405,CNMSH640.406,CNMSH640.407,CNMSH640.408,CNMSH640.40b, \
  CNMSH640.40c,CNMSH640.40e,CNMSH640.410,CNMSH640.413,CNMSH640.414, \
  CNMSH640.415,CNMSH640.419,CNMSH640.41d,CNMSH640.816,CNMSH640.c0a, \
  CNMSH64.CNT,CNMSH64.HLP,CNMSM64.EXE,CNMSQ64.EXE,CNMSR640.405, \
  CNMSR640.406,CNMSR640.407,CNMSR640.408,CNMSR640.40b,CNMSR640.40c, \
  CNMSR640.40e,CNMSR640.410,CNMSR640.413,CNMSR640.414,CNMSR640.415, \
  CNMSR640.419,CNMSR640.41d,CNMSR640.816,CNMSR640.c0a,CNMSR64.DLL, \
  CNMSS64.SMR,CNMST640.405,CNMST640.406,CNMST640.407,CNMST640.408, \
  CNMST640.40b,CNMST640.40c,CNMST640.40e,CNMST640.410,CNMST640.413, \
  CNMST640.414,CNMST640.415,CNMST640.419,CNMST640.41d,CNMST640.816, \
  CNMST640.c0a,CNMUB64.DLL,CNMUR640.405,CNMUR640.406,CNMUR640.407, \
  CNMUR640.408,CNMUR640.40b,CNMUR640.40c,CNMUR640.40e,CNMUR640.410, \
  CNMUR640.413,CNMUR640.414,CNMUR640.415,CNMUR640.419,CNMUR640.41d, \
  CNMUR640.816,CNMUR640.c0a,CNMUR64.DLL,CNMW364.DLL' WORF

This gives me the following error:

ERROR: string overflow by 1 (1024 - 1023) in safe_strcpy [adddriver "Windows NT x86" \
  Canon_PIXMA_iP4000:]
Usage: adddriver <Environment> \
        <Long Printer Name>:<Driver File Name>:<Data File Name>:\
        <Config File Name>:<Help File Name>:<Language Monitor Name>:\
        <Default Data Type>:<Comma Separated list of Files> \
        [version]

Is there a limit in the number of files ? Can I somehow patch the source, so Samba is able to handle e.g. 2048 characters for the addprinter command ?
Comment 1 Guenther Deschner 2009-02-25 06:07:33 UTC
Cannot reproduce this, neither with 3.3.1 nor with current master. Sorry, but no idea when in the past years this got fixed.