Bug 3998 - add user script problems on Solaris 9 SPARC
Summary: add user script problems on Solaris 9 SPARC
Status: RESOLVED FIXED
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts (show other bugs)
Version: 3.0.23a
Hardware: Sparc Solaris
: P3 critical
Target Milestone: none
Assignee: Samba Bugzilla Account
QA Contact: Samba QA Contact
URL: http://www.waermi.de
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-03 14:58 UTC by Thorsten Stettin
Modified: 2006-08-03 15:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Stettin 2006-08-03 14:58:34 UTC
Lower case/upper case problem when trying Windows XP/2003 machines with add user script like this: 
add machine script = /usr/sbin/useradd -d /dev/null -g 400 -s /bin/false %u

The issue is that there is a machine(user) name in lower case in the passwd file and in the smbpasswd file it is in upper case, so when smbd tries to set the machine password it fails. 

It works in version 3.22 without any problems. Of course, the passdb backend is smbpasswd.

Regards

Thorsten
Comment 1 Gerald (Jerry) Carter 2006-08-03 15:00:39 UTC
already fixed in SVN for 3.0.23b (cmoing soon).