Bug 3973 - Uppcase-problem with "add machine script"
Uppcase-problem with "add machine script"
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.23a
Other Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-28 06:34 UTC by Sven Strickroth
Modified: 2006-07-29 18:37 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Strickroth 2006-07-28 06:34:48 UTC
after an upgrade from 3.0.21b to 3.0.23a "add machine script" makes problems.
The script gets correctly executed, but the machine-account is uppercase now, useradd requires it to be lowercase.
Comment 1 Sven Strickroth 2006-07-28 06:41:15 UTC
To be more clear:
(i don't know if the machine-name was lowercase in 3.0.21b), because my add-machine-script lowercases it first, befor passing to useradd. - The problem is now, that the unix-account is lowercase and the entry in smbpasswd is added uppercase.

e.g.
/etc/passwd:
pc40$:x:1040:421:Workstation:/dev/null:/bin/false

/etc/samba/smbpasswd
PC40$:1040:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DW         ]:LCT-00000000:

samba logs this:
Jul 28 12:15:06 fileserver smbd_vscan-clamav[19734]: [2006/07/28 12:15:06, 0] passdb/pdb_smbpasswd.c:build_sam_account(1202)
Jul 28 12:15:06 fileserver smbd_vscan-clamav[19734]:   build_sam_account: smbpasswd database is corrupt!  username PC40$ with uid 1040 is not in unix passwd database!

so the error is that the name isn't stored lowercase in smbasswd any more.
Comment 2 Gerald (Jerry) Carter 2006-07-29 18:37:04 UTC
already fixed in SAMBA_3_0_23.