Bug 3970 - smbd crashes periodically with SIGIO
smbd crashes periodically with SIGIO
Status: RESOLVED DUPLICATE of bug 3912
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.23a
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 14:27 UTC by Orion Poplawski
Modified: 2006-07-27 16:37 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Orion Poplawski 2006-07-27 14:27:57 UTC
On FC4 server with samba-3.0.23a-1.fc4.1 and kernel 2.6.17-1.2142_FC4, we are seeing smbd crash periodically with SIGIO.  This causes the windows client to report "Delayed Write Failed".  It appears that it recovers and reconnects afterwards, but apparently data could be lost.

Example strace:

21136 13:06:09 getegid32()              = 0
21136 13:06:09 setgroups32(3, [1001, 1002, 1020]) = 0
21136 13:06:09 setresgid32(-1, 1001, -1) = 0
21136 13:06:09 getegid32()              = 1001
21136 13:06:09 setresuid32(1017, 1017, -1) = 0
21136 13:06:09 geteuid32()              = 1017
21136 13:06:09 fcntl64(11, F_SETLKW64, {type=F_UNLCK, whence=SEEK_SET, start=7124, len=1}, 0xbfb424a4) = 0
21136 13:06:09 --- SIGIO (I/O possible) @ 0 (0) ---
21136 13:06:09 +++ killed by SIGIO +++

A mention on the mailing list extists as well:

http://lists.samba.org/archive/samba-technical/2006-February/045477.html
Comment 1 Volker Lendecke 2006-07-27 14:30:42 UTC
But 3912 has a similar error. Can you try with 'kernel oplocks = no'?

Thanks,

Volker
Comment 2 Orion Poplawski 2006-07-27 16:37:29 UTC

*** This bug has been marked as a duplicate of 3912 ***