Bug 3967 - Problem accessing shares after upgrade to 3.0.23a with smbclient
Problem accessing shares after upgrade to 3.0.23a with smbclient
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.23a
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 08:06 UTC by Thorsten Hamester
Modified: 2006-08-04 12:20 UTC (History)
3 users (show)

See Also:


Attachments
tcpdump -s 1024 -vvvnNw tcpdump.raw not port ssh (18.80 KB, application/octet-stream)
2006-07-27 08:08 UTC, Thorsten Hamester
no flags Details
smbclient //192.168.100.118/Axapta_Dokumente -d 10 -k -U Administrator -l /root/ (308.97 KB, text/plain)
2006-07-27 08:08 UTC, Thorsten Hamester
no flags Details
Proposed patch (11.16 KB, patch)
2006-07-28 15:09 UTC, Jeremy Allison
no flags Details
Patch (12.15 KB, patch)
2006-07-28 16:13 UTC, Jeremy Allison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Hamester 2006-07-27 08:06:49 UTC
after upgrading my debian Sarge distribution with apt-get to 3.0.23
i have some troubles to access 3 shares on Windows 2000 and 2003 Server.
When trying to access them over smbclient i get the following error messages:
 
:~# smbclient //ente/Axapta_Dokumente -U Administrator -d 2
added interface ip=192.168.100.121 bcast=192.168.100.255 nmask=255.255.255.0
Password:
Domain=[APE-BERLIN] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]
smb: \> ls
client_check_incoming_message: received message with mid 9 with no matching send record.
SMB Signature verification failed on incoming packet!
Server packet had invalid SMB signature! listing \*
Error in dskattr: Server packet had invalid SMB signature!
 
With kerberos authentication i get the same error but different mid number.
 
My smb.conf lists a server signing = auto

I can not figure out how to attach level 10 logfile and raw tcpdump file, sorry
Comment 1 Thorsten Hamester 2006-07-27 08:08:10 UTC
Created attachment 2066 [details]
tcpdump -s 1024 -vvvnNw tcpdump.raw not port ssh
Comment 2 Thorsten Hamester 2006-07-27 08:08:56 UTC
Created attachment 2067 [details]
smbclient //192.168.100.118/Axapta_Dokumente -d 10 -k -U Administrator -l /root/
Comment 3 Jean-pierre Cartal 2006-07-28 02:25:27 UTC
Same problem for me, a detailed description with log file is available here :
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=200362
Comment 4 Jeremy Allison 2006-07-28 11:50:14 UTC
I think I understand the problem - give me a little while to create a patch.
Jeremy.
Comment 5 Jeremy Allison 2006-07-28 15:09:26 UTC
Created attachment 2074 [details]
Proposed patch

Please try this patch. This should fix the secondary trans2 replies signing issue.
If you ok it I'll include it in 3.0.23b.
Jeremy.
Comment 6 Jeremy Allison 2006-07-28 16:13:09 UTC
Created attachment 2075 [details]
Patch

Slightly better patch that enters the trans state after the first trans call send - this will work for receiving secondary and subsequent replies. I'm committing this to SAMBA_3_0 and SAMBA_3_0_23. PLEASE TEST !
Jeremy.
Comment 7 Gerald (Jerry) Carter 2006-08-04 12:19:31 UTC
Fixed.
Comment 8 Gerald (Jerry) Carter 2006-08-04 12:20:22 UTC
*** Bug 3968 has been marked as a duplicate of this bug. ***