Bug 3963 - unix password sync: passwd program seems to not be called
unix password sync: passwd program seems to not be called
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: smbldap-tools
3.0.14a
x86 Linux
: P3 normal
: none
Assigned To: Tournier Jerome
smbldap-tools team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-25 10:45 UTC by Michael Flegl
Modified: 2010-09-04 07:13 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Flegl 2006-07-25 10:45:19 UTC
Using Samba with LDAP (fedora-ds) the "unix password sync" function by calling
"passwd program = /usr/local/sbin/smbldap-passwd -u %u" using 
"passwd chat = *New*password*%n\n *Retype*new*password* %n\n" is not working.
"unix password sync = Yes" is set. It seems the passwd program is not called.
Executing smbldap-passwd on the command line is working fine.
Since I found a discussion here:
http://www.mail-archive.com/samba@lists.samba.org/msg75452.html
I'm not the only one with this problem. I could not find any update in the release notes for the newest samba version. I guess the problem might be a bug.
Tanks in advance, thanks for samba,
Michael.
Comment 1 Tournier Jerome 2006-07-26 01:59:54 UTC
The "passwd chat" must be related to the smbldap-passwd output. Can you try with this:
passwd chat = "Changing password for*\nNew password*" %n\n "*Retype new password*" %n\n"
Comment 2 Michael Flegl 2006-07-26 04:31:13 UTC
(In reply to comment #1)
> The "passwd chat" must be related to the smbldap-passwd output. Can you try
> with this:
> passwd chat = "Changing password for*\nNew password*" %n\n "*Retype new
> password*" %n\n"
> 

I tried:
passwd chat = "Changing UNIX password for*\nNew password*"%n\n"*Retype new password*"%n\n
as well as:
passwd chat = "Changing UNIX password for*\nNew password*" %n\n "*Retype new password*" %n\n
This makes no change. The same behaviour. Once again, from what we figured out earlier I'm really sure that the passwd program is not called by samba. If this would be true, the chat dialogue doesn't matter.
Hopefully to have a solution, Michael.
Comment 3 ready 2008-04-30 11:16:08 UTC
I have confirmed that Samba is not even calling the unix passwd program.

I created a script to collect the passwd sync activity from Samba (/root/passwd.fake instead of /usr/bin/passwd %u).

I am running Samba 3.0.25b-1.el5_1.4 on RHEL5.1.
Comment 4 Tournier Jerome 2010-09-04 07:13:53 UTC
Not maintained anymore